summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2013-02-27 15:06:11 +0100
committerMichael Stahl <mstahl@redhat.com>2013-02-27 17:09:45 +0100
commitfdd44e2d6ccb7db99185e76b1ed367b9cd24a090 (patch)
tree4f9ea9c5081fc0d29793bc9b31f4e0d3bc470760 /configure.ac
parent166a79df88853847528d558ea98656ad358f4645 (diff)
move generation of sal/udkversion.h to configure
Change-Id: I401dc6b3dcea933d1f186a8618e7c86ccd21430e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1b5e662003a6..0064e834eb49 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4177,6 +4177,14 @@ dnl ===================================================================
dnl Our version is defined by the AC_INIT() at the top of this script.
dnl ===================================================================
+UDK_MAJOR=3
+UDK_MINOR=2
+UDK_MICRO=7
+
+AC_DEFINE_UNQUOTED(SAL_UDK_MAJOR,"$UDK_MAJOR")
+AC_DEFINE_UNQUOTED(SAL_UDK_MINOR,"$UDK_MINOR")
+AC_DEFINE_UNQUOTED(SAL_UDK_MICRO,"$UDK_MICRO")
+
set `echo AC_PACKAGE_VERSION | sed "s/\./ /g"`
LIBO_VERSION_MAJOR=$1
@@ -11871,6 +11879,7 @@ AC_CONFIG_HEADERS([config_host/config_global.h])
AC_CONFIG_HEADERS([config_host/config_graphite.h])
AC_CONFIG_HEADERS([config_host/config_telepathy.h])
AC_CONFIG_HEADERS([config_host/config_typesizes.h])
+AC_CONFIG_HEADERS([config_host/config_udkversion.h])
AC_CONFIG_HEADERS([config_host/config_vclplug.h])
AC_CONFIG_HEADERS([config_host/config_version.h])
AC_OUTPUT