summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Foley <pefoley2@verizon.net>2013-03-02 18:48:33 -0500
committerPeter Foley <pefoley2@verizon.net>2013-03-03 16:08:04 -0500
commit96017f081f166c7c5649c43ad4f455f2c7805713 (patch)
tree53fe424dc8967db439bcba105dae40b23f2878c4 /configure.ac
parentac3e90b596170c31073c36cb9473aee6d59fbdde (diff)
fixup configure output
Change-Id: I1ec6261e1f5a34a9c1f00d874aa5191368034f4c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 62d2f783ad73..ed90a4b0bac5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5039,8 +5039,9 @@ if test "$GXX" = "yes"; then
dnl see https://code.google.com/p/android/issues/detail?id=41770
if test "$_gpp_majmin" -ge "407"; then
glibcxx_threads=no
- AC_MSG_CHECKING([whether $CXX is broken with boost.thread])
AC_LANG_PUSH([C++])
+ AC_REQUIRE_CPP
+ AC_MSG_CHECKING([whether $CXX is broken with boost.thread])
AC_PREPROC_IFELSE([AC_LANG_PROGRAM([[
#include <bits/c++config.h>]],[[
#if !defined(_GLIBCXX_HAVE_GTHR_DEFAULT) \