summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@suse.cz>2013-03-01 10:05:55 +0100
committerLuboš Luňák <l.lunak@suse.cz>2013-03-01 10:08:39 +0100
commit8cbd48f732587653870dc5996aef8af2db1fb51b (patch)
tree677618fc28336dc810903578f58fdfdef4d6e89b /configure.ac
parenta42649c6743a54498375903b4357c4c0545fbab8 (diff)
avoid relinking on windows after every configure run
Since 2ba9023a60f41f5ba414fa0f7682ac8104b3a00b WinResTarget depends on solenv_inc, which eventually depends on solenv/inc/minor.mk , which means relinking all libraries on Windows after each configure run. As AC_CONFIG_FILES updates generated files unconditionally, use a temporary and update only when it's actually changed. Change-Id: Ie5503ed7cdf307ab51935d271e9f1603b5e8f987
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e6f78a731786..de10a0e20511 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11827,7 +11827,18 @@ if test -f config_host.mk; then
config_md5=`$MD5SUM config_host.mk | sed "s/ .*//"`
fi
-AC_CONFIG_FILES([config_host.mk Makefile lo.xcent solenv/inc/minor.mk instsetoo_native/util/openoffice.lst])
+AC_CONFIG_FILES([config_host.mk Makefile lo.xcent instsetoo_native/util/openoffice.lst])
+# Unlike AC_CONFIG_HEADERS, AC_CONFIG_FILES updates the target file even if the contents
+# would be unchanged, avoid that.
+AC_CONFIG_FILES([solenv/inc/minor.mk.tmp:solenv/inc/minor.mk.in],
+ [
+ AC_MSG_NOTICE([creating solenv/inc/minor.mk])
+ if diff solenv/inc/minor.mk.tmp solenv/inc/minor.mk >/dev/null 2>&1 ; then
+ AC_MSG_NOTICE([solenv/inc/minor.mk is unchanged])
+ else
+ cp -f solenv/inc/minor.mk.tmp solenv/inc/minor.mk
+ fi
+ ])
AC_CONFIG_HEADERS([config_host/config_clang.h])
AC_CONFIG_HEADERS([config_host/config_global.h])
AC_CONFIG_HEADERS([config_host/config_graphite.h])