summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-01-09 22:34:45 +0100
committerMichael Stahl <mstahl@redhat.com>2014-01-10 00:21:52 +0100
commit415dfd0d89f550268dc66d4e7d447c1975a8aa44 (patch)
treea5f47bf39de7975510030c71b7dee817f1287244 /configure.ac
parent3b3c8c4796a89a76ce7574908096a91993412523 (diff)
configure: check for ICE and SM libraries too
Change-Id: Id86b09c9f2fe8770da8cc6b13672e2bf37201962
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 689b122e43ac..f41c691272ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9263,6 +9263,14 @@ if test "$WANT_X11" = "yes"; then
dnl ===================================================================
AC_CHECK_HEADERS(X11/extensions/shape.h,[],[AC_MSG_ERROR([libXext headers not found])],
[#include <X11/extensions/shape.h>])
+
+ # vcl needs ICE and SM
+ AC_CHECK_HEADERS(X11/ICE/ICElib.h,[],[AC_MSG_ERROR([libICE headers not found])])
+ AC_CHECK_LIB([ICE], [IceConnectionNumber], [:],
+ [AC_MSG_ERROR(ICE library not found)])
+ AC_CHECK_HEADERS(X11/SM/SMlib.h,[],[AC_MSG_ERROR([libSM headers not found])])
+ AC_CHECK_LIB([SM], [SmcOpenConnection], [:],
+ [AC_MSG_ERROR(SM library not found)])
fi
dnl ===================================================================