summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2014-01-15 10:28:01 +0200
committerTor Lillqvist <tml@collabora.com>2014-01-15 10:29:53 +0200
commit0b3513f34d1b930c17f42ac2cadad7fa43636848 (patch)
treee5303b9ca5427e174bd1ea7a519757fac920df07 /configure.ac
parent8c6342c25896e515869500f538370de336b123c7 (diff)
Let's always use libc++ when building for iOS against a current SDK
I have been using it for a while and it seems to work fine. No need to default to libstdc++. Change-Id: Ifa6999921b1333317c112f57fa402188f787d27d
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index d4a6a13a79c7..4c64535f567a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1241,8 +1241,7 @@ AC_ARG_WITH(macosx-bundle-identifier,
AC_ARG_ENABLE(libc++,
AS_HELP_STRING([--enable-libc++],
[Use the libc++ C++ library instead of GNU libstdc++ on OS X. Only effective
- if --with-macosx-version-min-required is 10.7 or later. Experimental work in
- progress, very likely breaks something, don't use unless you plan to fix that.]),
+ if --with-macosx-version-min-required is 10.7 or later.]),
,)
AC_ARG_ENABLE(ios-simulator,
@@ -3001,7 +3000,9 @@ if test $_os = iOS; then
# Just add -fvisibility=hidden to CC and CXX directly so that the 3rd-party libs also
# get compiled with it, to avoid ld warnings when linking all that together into one
# executable.
- # Use libc++ if opted in only, and only when building against iOS 7 SDK or newer.
+
+ # Use libc++ for iOS 7 SDK and libstdc++ for earlier (but we don't really expect anybody to
+ # be be using an earlier SDK)
XCODE_CLANG_CXX_LIBRARY=libstdc++
case $ios_sdk in
@@ -3011,9 +3012,10 @@ if test $_os = iOS; then
fi
;;
*)
- if test "$enable_libc__" = yes; then
- XCODE_CLANG_CXX_LIBRARY=libc++
+ if test "$enable_libc__" = no; then
+ AC_MSG_ERROR([--disable-libc++ not allowed])
fi
+ XCODE_CLANG_CXX_LIBRARY=libc++
;;
esac