summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-11-22 19:57:38 +0100
committerStephan Bergmann <sbergman@redhat.com>2018-11-23 08:20:53 +0100
commitf23aa1a51cb1beea4ebe3a61ba0c9b3abd844fd9 (patch)
treea7f6190e22719780c3102fca2ec5a368e29075bb /configure.ac
parent80cf278d365a2d357c70b8c28947c91fa97e7a99 (diff)
Bump compiler plugins Clang baseline to 5.0.2
...as discussed at <https://lists.freedesktop.org/archives/libreoffice/2018-November/081435.html> "minutes of ESC call ..." Change-Id: Ia053da171d59747984546f38e19da808825b4f79 Reviewed-on: https://gerrit.libreoffice.org/63832 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index bc165bd6b31a..827b5f6c995e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6698,9 +6698,9 @@ if test "$COM_IS_CLANG" = "TRUE"; then
else
compiler_plugins=no
fi
- if test "$compiler_plugins" != no -a "$CLANGVER" -lt 30800; then
+ if test "$compiler_plugins" != no -a "$CLANGVER" -lt 50002; then
if test "$compiler_plugins" = yes; then
- AC_MSG_ERROR([Clang $CLANGVER is too old to build compiler plugins; need >= 3.8.0.])
+ AC_MSG_ERROR([Clang $CLANGVER is too old to build compiler plugins; need >= 5.0.2.])
else
compiler_plugins=no
fi