summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-11-21 22:07:11 +0100
committerStephan Bergmann <sbergman@redhat.com>2018-11-22 08:22:16 +0100
commitf15274a9d93b7b88d459b0cdb6b3d49e6479a4c1 (patch)
treef362d23f393ce07a7e3861ed242ac843994beba6 /configure.ac
parent9decbd5998dc93549ef9f0268e86f53634071600 (diff)
Completely remove obsolete HAVE_BROKEN_STATIC_INITIALIZER_LIST check
...after it had already been phased out almost two years ago with 721116c7ade10d76e3ed6832e3988c91427ba431 "Phase out support for HAVE_BROKEN_STATIC_INITIALIZER_LIST" Change-Id: Idfc216f10ecff9dab6a3218ba234d458d7816839 Reviewed-on: https://gerrit.libreoffice.org/63766 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 0 insertions, 34 deletions
diff --git a/configure.ac b/configure.ac
index c5591303209b..bc165bd6b31a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12530,40 +12530,6 @@ if test "$broken" = yes; then
fi
-AC_MSG_CHECKING([whether $CXX has broken static initializer_list support])
-save_CXXFLAGS=$CXXFLAGS
-CXXFLAGS="$CXXFLAGS $CXXFLAGS_CXX11"
-save_LIBS=$LIBS
-if test -n "$ILIB1"; then
- LIBS="$LIBS $ILIB1"
-fi
-AC_LANG_PUSH([C++])
-AC_RUN_IFELSE([AC_LANG_PROGRAM([[
- // Exit with failure if the static initializer_list is stored on the
- // stack (as done by Clang < 3.4):
- #include <initializer_list>
- struct S {};
- bool g(void const * p1, void const * p2) {
- int n;
- return !((p1 > p2 && p2 > &n) || (p1 < p2 && p2 < &n));
- }
- bool f(void const * p1) {
- static std::initializer_list<S> s { S() };
- return g(p1, s.begin());
- }
- ]],[[
- int n;
- return f(&n) ? 0 : 1;
- ]])], [broken=no], [broken=yes],[broken='assuming not (cross-compiling)'])
-AC_LANG_POP([C++])
-LIBS=$save_LIBS
-CXXFLAGS=$save_CXXFLAGS
-AC_MSG_RESULT([$broken])
-if test "$broken" = yes -a "$_os" != "iOS"; then
- AC_MSG_ERROR([working support for static initializer_list needed])
-fi
-
-
# ===================================================================
# Creating bigger shared library to link against
# ===================================================================