summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-09-11 17:45:15 +0200
committerStephan Bergmann <sbergman@redhat.com>2018-09-12 07:53:19 +0200
commit9c6880bb0771fe2cd6523a4d2488c403e5480163 (patch)
treef3389f2e3dab9bc19d60eac29d8164e5018c74bb /configure.ac
parente87143222934ee730806be9f8f7d083133566ad7 (diff)
Make sure MSVC actually warns/errors on unknown attribute
...as "warning C5030: attriubte '...' is not recognized" is not inclued in the default /W1. Change-Id: I89acfa34df3c361e572c59d197d0c26b68abbeee Reviewed-on: https://gerrit.libreoffice.org/60332 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 87ee1fdbd756..685408e99062 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6443,7 +6443,7 @@ save_CXXFLAGS=$CXXFLAGS
CXXFLAGS="$CXXFLAGS $CXXFLAGS_CXX11"
dnl Unknown attributes must be ignored by compilers, but they do emit warnings about them:
if test "$COM" = MSC; then
- CXXFLAGS="$CXXFLAGS /WX"
+ CXXFLAGS="$CXXFLAGS /we5030"
else
CXXFLAGS="$CXXFLAGS -Werror"
fi