summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-11-27 16:40:56 +0100
committerStephan Bergmann <sbergman@redhat.com>2018-11-27 20:43:06 +0100
commit978a8357b25f2f319d3783cc6a58a6be79facac3 (patch)
treeffa394dcd506589eb00bea18c658a945b525bec2 /configure.ac
parent0d4298a9880e48692871b5b3d4bbc551af6e37ae (diff)
Remove --enable-c++17 option
...reverting 0f3b0ec973f06a98c75ef8acfa720a9973e4d2b5 "Avoid C++17 mode for Coverity Scan". As far as I understand, <https://lists.freedesktop.org/archives/libreoffice/2018-November/081454.html> "New Defects reported by Coverity Scan for LibreOffice" has been run against dd0e6849297c18aabe4fc29c0340a2ed1e474eaf "Temporarily drop --disable-c++17 from Coverity builds" but doesn't let issues like the one discussed at <https://lists.freedesktop.org/archives/libreoffice/2017-November/078966.html> "Re: New Defects reported by Coverity Scan for LibreOffice" reappear. So disabling C++17 for Coverity Scan builds appears to no longer be necessary. Change-Id: I22bfd9ad61da00e942a87aa5e1e0d1fab0004d49 Reviewed-on: https://gerrit.libreoffice.org/64121 Reviewed-by: Caolán McNamara <caolanm@redhat.com> Tested-by: Caolán McNamara <caolanm@redhat.com> Tested-by: Jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 1 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index b35ceab44ad1..13d4afa1240d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6179,12 +6179,6 @@ dnl ===================================================================
dnl C++11
dnl ===================================================================
-my_cxx17switches=
-libo_FUZZ_ARG_ENABLE(c++17,
- AS_HELP_STRING([--disable-c++17],
- [Do not attempt to run GCC/Clang in C++17 mode (needed for Coverity).])
-)
-
AC_MSG_CHECKING([whether $CXX supports C++17, C++14, or C++11])
CXXFLAGS_CXX11=
if test "$COM" = MSC -a "$COM_IS_CLANG" != TRUE; then
@@ -6193,10 +6187,7 @@ elif test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
dnl But only use C++17 if the gperf that is being used knows not to emit
dnl "register" in C++ output:
printf 'foo\n' | $GPERF -L C++ > conftest.inc
- my_flags='-std=gnu++14 -std=gnu++1y -std=c++14 -std=c++1y -std=gnu++11 -std=gnu++0x -std=c++11 -std=c++0x'
- if test "$enable_c__17" != no; then
- my_flags="-std=gnu++2a -std=c++2a -std=gnu++17 -std=gnu++1z -std=c++17 -std=c++1z $my_flags"
- fi
+ my_flags='-std=gnu++2a -std=c++2a -std=gnu++17 -std=gnu++1z -std=c++17 -std=c++1z -std=gnu++14 -std=gnu++1y -std=c++14 -std=c++1y -std=gnu++11 -std=gnu++0x -std=c++11 -std=c++0x'
for flag in $my_flags; do
if test "$COM" = MSC; then
flag="-Xclang $flag"