summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-08-16 17:38:52 +0200
committerStephan Bergmann <sbergman@redhat.com>2018-11-28 13:51:04 +0100
commit206b8c4ae320d7d8614f21800d8f77fa29f8f5ff (patch)
tree294d7299431b329ef6413aef201a2245d40c7b9d /configure.ac
parent01de2fbdedc693dc46c6d3fde276820a52b42a9c (diff)
On Windows, check for at least Visual Studio 2017 version 15.7
...to further restrict the Windows MSVC baseline to not just VS 2017, but to the latest update (as the various updates bring significant improvements for C++11/ 14/17 support; see the mailing list thread starting at <https://lists.freedesktop.org/archives/libreoffice/2018-July/080588.html> "Compiler baselines (was: [Libreoffice-qa] minutes of ESC call ...)"). Change-Id: If6a1b62da1691ae8ae19edb4ed7b35e4b6e46501 Reviewed-on: https://gerrit.libreoffice.org/59209 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4134f6460e16..426bbdf3cba0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3561,6 +3561,15 @@ if test "$_os" = "WINNT"; then
AC_MSG_ERROR([Visual C++ not found after all, huh])
fi
+ AC_MSG_CHECKING([$CC is at least Visual Studio 2017 version 15.7])
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ // See <https://docs.microsoft.com/en-us/cpp/preprocessor/predefined-macros> for mapping
+ // between Visual Studio versions and _MSC_VER:
+ #if _MSC_VER < 1914
+ #error
+ #endif
+ ]])],[AC_MSG_RESULT([yes])],[AC_MSG_ERROR([no])])
+
# Check for 64-bit (cross-)compiler to use to build the 64-bit
# version of the Explorer extension (and maybe other small
# bits, too) needed when installing a 32-bit LibreOffice on a