summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-11-21 13:28:23 +0100
committerStephan Bergmann <sbergman@redhat.com>2018-11-28 12:07:13 +0100
commit09b8d1f480b22581f8ef31c2611f4bb7366b53c0 (patch)
tree906ac4ce2d2e1a262eb1a75269d9ac347af66594 /configure.ac
parent9c56e63c434be69d94a81078b7d5491a5775c8e0 (diff)
Require at least flex 2.6.0, which no longer emits "register"
...according to <https://github.com/westes/flex/blob/ 83d5d1695a2ab1d69ea4d8e7df27146c644876fc/NEWS>. Its use is no longer allowed in C++17, so will start to cause build failures once we restrict builds to at least C++17. (The situation with gperf is similar, but instead of checking for a minimal known-good version that no longer emits "register", we instead check for it indirectly in configure.ac, by creating gperf-produced conftest.inc and including that in the program used to test which -std= value to use. We could have done something similar for flex, but creating suitable flex output for inclusion might be more work than it was for the simple gperf case.) Change-Id: I662c6795ea5fde1420d9712c0ec910c0cadbc350 Reviewed-on: https://gerrit.libreoffice.org/63713 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 13d4afa1240d..17672abcb8f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9850,8 +9850,8 @@ if test -z "$FLEX"; then
else
AC_MSG_CHECKING([the flex version])
_flex_version=$($FLEX --version | $SED -e 's/^.*\([[[:digit:]]]\{1,\}\.[[[:digit:]]]\{1,\}\.[[[:digit:]]]\{1,\}\).*$/\1/')
- if test $(echo $_flex_version | $AWK -F. '{printf("%d%03d%03d", $1, $2, $3)}') -lt 2005035; then
- AC_MSG_ERROR([failed ($FLEX $_flex_version found, but need at least 2.5.35)])
+ if test $(echo $_flex_version | $AWK -F. '{printf("%d%03d%03d", $1, $2, $3)}') -lt 2006000; then
+ AC_MSG_ERROR([failed ($FLEX $_flex_version found, but need at least 2.6.0)])
fi
fi
AC_SUBST([FLEX])