summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRiccardo Magliocchetti <riccardo.magliocchetti@gmail.com>2014-11-04 16:26:45 +0100
committerMichael Meeks <michael.meeks@collabora.com>2014-11-05 09:55:57 +0000
commitc716b3888e7e8150d1c1053ee6550afb56438b1f (patch)
treea4dd334df679a623de436021795587d138724498 /configure.ac
parent6cc8ed7d64b4c01550539170c1848f1152e433af (diff)
Add build support for iwyu
include-what-you-use is a tool to help removing unneeded includes. Homepage: https://code.google.com/p/include-what-you-use/ So to use it pass its path to configure like: ./configure --with-iwyu=/usr/bin/include-what-you-use May be helpful for fdo#42949 Change-Id: Idc185c5181d754b9dfd82fcf6a5ad05953b3cd03 Reviewed-on: https://gerrit.libreoffice.org/12255 Reviewed-by: Michael Meeks <michael.meeks@collabora.com> Tested-by: Michael Meeks <michael.meeks@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 84505ba67215..26f7b79de9ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2093,6 +2093,12 @@ AC_ARG_WITH(gssapi,
where a good system GSSAPI is available.]),
,)
+AC_ARG_WITH(iwyu,
+ AS_HELP_STRING([--with-iwyu],
+ [Provide IWYU binary path to check unneeded includes instead of building.
+ Use only if you are hacking on it.]),
+,)
+
dnl ===================================================================
dnl Branding
dnl ===================================================================
@@ -12503,6 +12509,8 @@ else
fi
AC_SUBST(PARALLELISM)
+IWYU_PATH="$with_iwyu"
+AC_SUBST(IWYU_PATH)
#
# Set up ILIB for MSVC build
#