summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2014-10-23 12:58:56 +0300
committerTor Lillqvist <tml@collabora.com>2014-10-23 13:02:28 +0300
commit6addde24f43d4d77cd459ef1d34df84cdad49d8f (patch)
treea032d80d8fce9343ccd161bf2701f834484949a7 /configure.ac
parent2593d96b8d03fd1d4f17b05882a09687c47471c5 (diff)
Add --enable-sal-info
Change-Id: I014d70ace7ce34b804ea2a018d3de8f94f7e0cbc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 950784790e18..a72e4a8a9290 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1015,6 +1015,10 @@ AC_ARG_ENABLE(debug,
[Include debugging information, disable compiler optimization and inlining plus
extra debugging code like assertions. Extra large build! (enables -g compiler flag).]))
+AC_ARG_ENABLE(sal-info,
+ AS_HELP_STRING([--enable-sal-info],
+ [Make SAL_INFO and SAL_WARN calls do something even in a non-debug build.]))
+
AC_ARG_ENABLE(selective-debuginfo,
AS_HELP_STRING([--enable-selective-debuginfo],
[If --enable-debug or --enable-dbgutil is used, build debugging information
@@ -3801,6 +3805,11 @@ AC_SUBST(ENABLE_DEBUG)
AC_SUBST(ANDROID_DEBUGGABLE)
AC_SUBST(ANDROID_INSTALL_LOCATION)
+if test "$enable_sal_info" = yes; then
+ ENABLE_SAL_INFO=TRUE
+fi
+AC_SUBST(ENABLE_SAL_INFO)
+
dnl Selective debuginfo
ENABLE_DEBUGINFO_FOR=
if test -n "$ENABLE_DEBUG"; then