summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>2019-07-09 11:44:21 +0900
committerTomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>2019-07-09 11:57:56 +0900
commit99e6eaf28c3cceb4fbf5292b255354dd1bdbe471 (patch)
tree39d1a3b390de07f138b97e411dc07941e271c511 /configure.ac
parentb7fa764f39631605d1ba1b5dba17373b82df2378 (diff)
use the specific header file for the SSE/AVX in intrin. detection
x86intrin.h is only available for gcc/clang, specific headers are available in all compilers (if they support that specific intrin. at all) Change-Id: Ic6dec052c150032f67ae76e0ca362c4bc77b55b0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b9785d895366..b76d977924ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6759,7 +6759,7 @@ if test "$GCC" = "yes"; then
save_CXXFLAGS=$CXXFLAGS
CXXFLAGS="$CXXFLAGS -msse2"
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
- #include <x86intrin.h>
+ #include <emmintrin.h>
int main () {
volatile __m128i a = _mm_set1_epi32 (0), b = _mm_set1_epi32 (0), c;
c = _mm_xor_si128 (a, b);
@@ -6782,7 +6782,7 @@ if test "$GCC" = "yes"; then
save_CXXFLAGS=$CXXFLAGS
CXXFLAGS="$CXXFLAGS -mssse3"
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
- #include <x86intrin.h>
+ #include <tmmintrin.h>
int main () {
volatile __m128i a = _mm_set1_epi32 (0), b = _mm_set1_epi32 (0), c;
c = _mm_maddubs_epi16 (a, b);
@@ -6805,7 +6805,7 @@ if test "$GCC" = "yes"; then
save_CXXFLAGS=$CXXFLAGS
CXXFLAGS="$CXXFLAGS -mavx"
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
- #include <x86intrin.h>
+ #include <immintrin.h>
int main () {
volatile __m256 a = _mm256_set1_ps (0.0f), b = _mm256_set1_ps (0.0f), c;
c = _mm256_xor_ps(a, b);
@@ -6828,7 +6828,7 @@ if test "$GCC" = "yes"; then
save_CXXFLAGS=$CXXFLAGS
CXXFLAGS="$CXXFLAGS -mavx2"
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
- #include <x86intrin.h>
+ #include <immintrin.h>
int main () {
volatile __m256i a = _mm256_set1_epi32 (0), b = _mm256_set1_epi32 (0), c;
c = _mm256_maddubs_epi16(a, b);