summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2019-06-05 02:06:00 +0300
committerTor Lillqvist <tml@collabora.com>2019-06-05 07:44:57 +0300
commit1e95c8dd006147f7a94e24135396277ee2f469b8 (patch)
treea03163476fe83f3d3a59c76626c8caa75f329b4c /configure.ac
parentc6ab40a2dd25d94786bda82aed85f086f00f050b (diff)
The Bluetooth code doesn't compile with macOS SDK 10.15
Change-Id: I8fffa4cef9628e6872c881cd0cbdfe85495fa324
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f03615124aa4..2122bf97d41c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10354,6 +10354,10 @@ if test -n "$enable_sdremote" -a "$enable_sdremote" != "no"; then
ENABLE_SDREMOTE=TRUE
AC_MSG_CHECKING([whether to enable Bluetooth support in Impress remote control])
+ if test $OS = MACOSX -a "$MAC_OS_X_VERSION_MAX_ALLOWED" -ge 101500; then
+ # The Bluetooth code doesn't compile with macOS SDK 10.15
+ enable_sdremote_bluetooth=no
+ fi
# If not explicitly enabled or disabled, default
if test -z "$enable_sdremote_bluetooth"; then
case "$OS" in