summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2020-04-20 11:40:24 +0200
committerTor Lillqvist <tml@collabora.com>2020-05-01 21:39:39 +0200
commitd996e8074ce122c887617c2c7fb20c4a67530aa3 (patch)
treee3ba0d90b30be4a0cdc4340c8febaebd7bfce89b /configure.ac
parentd4a24b61ec4d35aa41f49ffba85cd32154c25dbd (diff)
Add --with-latest-c++ to explicitly opt in for -std=c++20/-std:c++latest
cd472d1d8489f30797f47d3f6dafede28c1feb90 "Compile as C++2a, where available" had started to unconditionally check for support of -std=c++2a (and later also -std=c++20) for Clang and GCC, but that can cause occasional issues especially for Linux distros, see e.g. 55c724b93dfd4c9a1afb10d60fbc2d7a9a66cf61 "replace boost::bimap in sdext pdfimport" or <https://bugzilla.redhat.com/show_bug.cgi?id=1818723> "/usr/include/boost/format/alt_sstream_impl.hpp incompatible with -std=c++20 (std::allocator::allocate hint argument)" (where 677c8de4fa79cd9b278b142013ba7f1c9e4e41c3 "external/boost: Adapt to std::allocator parts removed in C++20" is not picked up due to --with-system-boost). So better require an explicit opt-in via a new --with-latest-c++. And while at it, also make that enable -std:c++latest for MSVC. Change-Id: I2d1f03144fad9a7884562e56b1b76cab5eb8f080 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/92555 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com> Reviewed-on: https://gerrit.libreoffice.org/c/core/+/93204 Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com> Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 15 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 76cc8f5f3ca8..c64fa51b7dbf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2144,6 +2144,12 @@ libo_FUZZ_ARG_WITH(lxml,
report widget classes and ids.]),
,)
+libo_FUZZ_ARG_WITH(latest-c++,
+ AS_HELP_STRING([--with-latest-c++],
+ [Try to enable the latest features of the C++ compiler, even if they are not yet part of a
+ published standard.]),,
+ [$with_latest_c__=no])
+
dnl ===================================================================
dnl Branding
dnl ===================================================================
@@ -6248,14 +6254,21 @@ libo_FUZZ_ARG_ENABLE(c++17,
AC_MSG_CHECKING([whether $CXX supports C++17, C++14, or C++11])
CXXFLAGS_CXX11=
if test "$COM" = MSC -a "$COM_IS_CLANG" != TRUE; then
- CXXFLAGS_CXX11=-std:c++17
+ if test "$with_latest_c__" = yes; then
+ CXXFLAGS_CXX11=-std:c++latest
+ else
+ CXXFLAGS_CXX11=-std:c++17
+ fi
elif test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
dnl But only use C++17 if the gperf that is being used knows not to emit
dnl "register" in C++ output:
printf 'foo\n' | $GPERF -L C++ > conftest.inc
my_flags='-std=gnu++14 -std=gnu++1y -std=c++14 -std=c++1y -std=gnu++11 -std=gnu++0x -std=c++11 -std=c++0x'
if test "$enable_c__17" != no; then
- my_flags="-std=gnu++2a -std=c++2a -std=gnu++17 -std=gnu++1z -std=c++17 -std=c++1z $my_flags"
+ my_flags="-std=gnu++17 -std=gnu++1z -std=c++17 -std=c++1z $my_flags"
+ if test "$with_latest_c__" = yes; then
+ my_flags="-std=gnu++2a -std=c++2a $my_flags"
+ fi
fi
for flag in $my_flags; do
if test "$COM" = MSC; then