summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDeve <deveee@gmail.com>2019-01-09 00:10:27 +0100
committerAndras Timar <andras.timar@collabora.com>2019-09-22 09:53:24 +0200
commitc2d39ea4288f14c0f9cc16320bd34b3199e907ff (patch)
tree281b3aadacab15cbc22816d4c9758bd602148743 /configure.ac
parent2310b4264ab550a8dc9d49e1e0dcecea5bde8d06 (diff)
Don't build dconf on Android and iOS.
Without that modification, it finds dconf in linux system and then compilation fails when it tries to build configmgr/source/dconf.cxx because dconf headers are not found in Android NDK. Change-Id: I25ab7f1ce66ed491f08a526e462e00957135b0c2 Reviewed-on: https://gerrit.libreoffice.org/65987 Tested-by: Jenkins Reviewed-by: Michael Stahl <Michael.Stahl@cib.de> (cherry picked from commit b534c1ef4ba439cc1b0f566ed9e3a3275a2e8e5e) Reviewed-on: https://gerrit.libreoffice.org/79342 Reviewed-by: Andras Timar <andras.timar@collabora.com> Tested-by: Andras Timar <andras.timar@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 189f0e36a6b0..0ecaa54ff976 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10512,7 +10512,7 @@ dnl =================================================
dnl Check whether to build with dconf support.
dnl =================================================
-if test "$enable_dconf" != no; then
+if test $_os != Android -a $_os != iOS -a "$enable_dconf" != no; then
PKG_CHECK_MODULES([DCONF], [dconf >= 0.15.2], [], [
if test "$enable_dconf" = yes; then
AC_MSG_ERROR([dconf not found])
@@ -10521,7 +10521,7 @@ if test "$enable_dconf" != no; then
fi])
fi
AC_MSG_CHECKING([whether to enable dconf])
-if test "$enable_dconf" = no; then
+if test $_os = Android -o $_os = iOS -o "$enable_dconf" = no; then
DCONF_CFLAGS=
DCONF_LIBS=
ENABLE_DCONF=