summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2019-06-10 21:40:33 +0200
committerJan-Marek Glogowski <glogow@fbihome.de>2019-06-13 23:45:09 +0200
commita6201725d760cbce832d4de029b418bb7334df6a (patch)
tree5fcb76c6179ba382b078f0a127427dc429c18109 /configure.ac
parent2d36e43d3d3ac69f4cacd532308cfc8c81982864 (diff)
Don't link avmediagst with gtk3 and qt5
While the VCL plugins are dynamically loaded and therefore just load their depending toolkit libraries, the GStreamer avmedia backend now links against Qt and GTK+. The GStreamer API itself is toolkit agnostic and the toolkit setup just uses a single GStreamer symbol to create the specific video sink. So the toolkit binding can simply be moved into the VCL plugin. At the point of the GStreamer toolkit setup call the GStreamer library is loaded by avmediagst, so the dlsym lookup should never fail. I also dropped the special GtkWidget handling. Using g_object_get will increase the refcount of the widget. A g_object_unref after adding it to the container seems to destroy it correctly. Change-Id: I693947e441bceb4b09bc38920e308e39142d0a35 Reviewed-on: https://gerrit.libreoffice.org/73849 Tested-by: Jenkins Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 16 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 5db4063c921f..56485ac37f6d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10512,6 +10512,7 @@ if test "$build_gstreamer_1_0" = "yes"; then
GSTREAMER_1_0_CFLAGS=$(printf '%s' "$GSTREAMER_1_0_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
FilterLibs "${GSTREAMER_1_0_LIBS}"
GSTREAMER_1_0_LIBS="${filteredlibs}"
+ AC_DEFINE(ENABLE_GSTREAMER_1_0)
else
AC_MSG_RESULT([no])
fi
@@ -11073,9 +11074,9 @@ QT5_CFLAGS=""
QT5_LIBS=""
QMAKE5="qmake"
MOC5="moc"
-QT5_GLIB_CFLAGS=""
-QT5_GLIB_LIBS=""
-QT5_HAVE_GLIB=""
+QT5_GOBJECT_CFLAGS=""
+QT5_GOBJECT_LIBS=""
+QT5_HAVE_GOBJECT=""
if test \( "$test_kde5" = "yes" -a "$ENABLE_KDE5" = "TRUE" \) -o \
\( "$test_qt5" = "yes" -a "$ENABLE_QT5" = "TRUE" \) -o \
\( "$test_gtk3_kde5" = "yes" -a "$ENABLE_GTK3_KDE5" = "TRUE" \)
@@ -11149,21 +11150,22 @@ then
the root of your Qt installation by exporting QT5DIR before running "configure".])
fi
- # Glib is needed for properly handling Qt event loop with Qt's Glib integration enabled.
- # Sets also QT5_GLIB_CFLAGS/QT5_GLIB_LIBS if successful.
- PKG_CHECK_MODULES(QT5_GLIB,[glib-2.0 >= 2.4],
- [
- QT5_HAVE_GLIB=1
- ],
- AC_MSG_WARN([[No Glib found, Qt5 support will not use native file pickers!]])
- )
+
+ if test "$build_gstreamer_1_0" = "yes"; then
+ PKG_CHECK_MODULES(QT5_GOBJECT,[gobject-2.0], [
+ QT5_HAVE_GOBJECT=1
+ AC_DEFINE(QT5_HAVE_GOBJECT)
+ ],
+ AC_MSG_WARN([[No GObject found, can't use QWidget GStreamer sink on wayland!]])
+ )
+ fi
fi
AC_SUBST(QT5_CFLAGS)
AC_SUBST(QT5_LIBS)
AC_SUBST(MOC5)
-AC_SUBST(QT5_GLIB_CFLAGS)
-AC_SUBST(QT5_GLIB_LIBS)
-AC_SUBST(QT5_HAVE_GLIB)
+AC_SUBST(QT5_GOBJECT_CFLAGS)
+AC_SUBST(QT5_GOBJECT_LIBS)
+AC_SUBST(QT5_HAVE_GOBJECT)
dnl ===================================================================
dnl KDE5 Integration