summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <Michael.Stahl@cib.de>2019-08-13 10:39:00 +0200
committerAndras Timar <andras.timar@collabora.com>2019-08-29 09:19:50 +0200
commit85f7dca685c8a3e591acaac11b806e4fae92f82f (patch)
treea01f1b418c56e0d039934beda81d0974d3a651f4 /configure.ac
parentf0814d1b8bb93ea08f9e0c275e6b83e0e422a159 (diff)
configure: don't enable export validation if there are no schemas
Schemas are excluded from tarballs since commit 34dced99c33a97dab86c4538fa267ad4ad4fb41f because of the license. Change-Id: I6540926d9ebb390d7956bbd1df3bb915adebb64b Reviewed-on: https://gerrit.libreoffice.org/77383 Tested-by: Jenkins Reviewed-by: Michael Stahl <Michael.Stahl@cib.de> (cherry picked from commit c78dd0a726b32d922a0d75a26a51d4c30612368c) Reviewed-on: https://gerrit.libreoffice.org/77393 Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de> Reviewed-on: https://gerrit.libreoffice.org/77914 Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com> Reviewed-by: Andras Timar <andras.timar@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9e86121fdfd5..8025a650167e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7415,6 +7415,12 @@ if test "$with_export_validation" != "no"; then
else
AC_MSG_RESULT([no, as Java is too old, need Java 8])
fi
+ elif ! test -d "${SRC_ROOT}/schema"; then
+ if test "$with_export_validation" = "yes"; then
+ AC_MSG_ERROR([requested, but schema directory is missing (it is excluded from tarballs)])
+ else
+ AC_MSG_RESULT([no, schema directory is missing (it is excluded from tarballs)])
+ fi
else
AC_MSG_RESULT([yes])
AC_DEFINE(HAVE_EXPORT_VALIDATION)