summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-12-13 09:43:55 +0100
committerJan Holesovsky <kendy@collabora.com>2019-10-09 10:39:46 +0200
commit80b04804d51742bf28183bb045765ccdf30425be (patch)
tree7d85b6a2634039ba373f670603ad2d63c69c814e /configure.ac
parent2943733ea4f4080a17a45b60690367d78bc79d5c (diff)
Introduce --enable-android-editing
...to select the experimental ...Editing... Android build variant. (Ignored for non-Android builds, but using libo_FUZZ_ARG_ENABLE anyway, just in case.) Change-Id: I670925ff358039e38edc29db69f48a78d484f133 Reviewed-on: https://gerrit.libreoffice.org/65077 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com> Reviewed-on: https://gerrit.libreoffice.org/80282 Reviewed-by: Jan Holesovsky <kendy@collabora.com> Tested-by: Jan Holesovsky <kendy@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2a9f12c7f094..98bac05ad20a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -526,6 +526,16 @@ if test -n "$with_android_sdk"; then
fi
AC_SUBST(ANDROID_SDK_HOME)
+libo_FUZZ_ARG_ENABLE([android-editing],
+ AS_HELP_STRING([--enable-android-editing],
+ [Enable the experimental editing feature on Android.])
+)
+ENABLE_ANDROID_EDITING=
+if test "$enable_android_editing" = yes; then
+ ENABLE_ANDROID_EDITING=TRUE
+fi
+AC_SUBST([ENABLE_ANDROID_EDITING])
+
dnl ===================================================================
dnl The following is a list of supported systems.
dnl Sequential to keep the logic very simple