summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Thibault <sthibault@hypra.fr>2018-02-16 13:22:10 +0100
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2018-02-20 22:21:48 +0100
commit226697ae27ef451cad404256e83eef88262f16d1 (patch)
tree30b3361c0bb8338139f3331473688a94318373ef /configure.ac
parent88560550021908b7877b7c02b4601b92f97ea7d4 (diff)
Integrate initial version of gla11y tool in the build system
This is part of integrating an accessibility non-regression tool. This adds checks in configure.ac for the presence of python lxml which we will need, and adds support for calling the tool at build time, to check for definite UI errors. For now, that only emits errors for missing or duplicate accessibility relation targets, and senseless relations: a label being mnemonic for several widgets. Change-Id: Idda91b15b9a9e0322d16db33dfac8e03f2aa518c Reviewed-on: https://gerrit.libreoffice.org/49856 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e20e91e7fa42..479968be94b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8148,10 +8148,19 @@ if test $enable_python = system; then
fi
dnl By now enable_python should be "system", "internal" or "no"
+PYTHON_LXML=
case $enable_python in
system)
SYSTEM_PYTHON=TRUE
+ AC_MSG_CHECKING([for python lxml])
+ if $PYTHON -c "import lxml.etree as ET" ; then
+ PYTHON_LXML=TRUE
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no, will not be able to check UI accessibility])
+ fi
+
dnl Check if the headers really work
save_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS $PYTHON_CFLAGS"
@@ -8213,6 +8222,7 @@ AC_SUBST(DISABLE_PYTHON)
AC_SUBST(SYSTEM_PYTHON)
AC_SUBST(PYTHON_CFLAGS)
AC_SUBST(PYTHON_LIBS)
+AC_SUBST(PYTHON_LXML)
AC_SUBST(PYTHON_VERSION)
AC_SUBST(PYTHON_VERSION_MAJOR)
AC_SUBST(PYTHON_VERSION_MINOR)