summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-01-09 22:34:45 +0100
committerCaolán McNamara <caolanm@redhat.com>2014-01-10 19:56:27 +0000
commit123a5a7079426d7d4cb6b980b384339d6150a0a8 (patch)
tree31a9edd414fdc2663e8396e60b4734680b92ef85 /configure.ac
parentba5c3753f736cdca9b6ffea4bf3db2e9b31d4ee2 (diff)
configure: check for ICE and SM libraries too
Change-Id: Id86b09c9f2fe8770da8cc6b13672e2bf37201962 (cherry picked from commit 415dfd0d89f550268dc66d4e7d447c1975a8aa44) Reviewed-on: https://gerrit.libreoffice.org/7349 Reviewed-by: Caolán McNamara <caolanm@redhat.com> Tested-by: Caolán McNamara <caolanm@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ccf270425b1c..4164d292135b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9199,6 +9199,14 @@ if test "$WANT_X11" = "yes"; then
dnl ===================================================================
AC_CHECK_HEADERS(X11/extensions/shape.h,[],[AC_MSG_ERROR([libXext headers not found])],
[#include <X11/extensions/shape.h>])
+
+ # vcl needs ICE and SM
+ AC_CHECK_HEADERS(X11/ICE/ICElib.h,[],[AC_MSG_ERROR([libICE headers not found])])
+ AC_CHECK_LIB([ICE], [IceConnectionNumber], [:],
+ [AC_MSG_ERROR(ICE library not found)])
+ AC_CHECK_HEADERS(X11/SM/SMlib.h,[],[AC_MSG_ERROR([libSM headers not found])])
+ AC_CHECK_LIB([SM], [SmcOpenConnection], [:],
+ [AC_MSG_ERROR(SM library not found)])
fi
dnl ===================================================================