summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2017-12-29 17:26:39 +0100
committerStephan Bergmann <sbergman@redhat.com>2017-12-30 11:34:26 +0100
commit494bdd3dc32287cc01ea4e0d81438a9266425726 (patch)
tree6cdbaf5f2c7dbc265410743b7ba0b152c3a90dad /configure.ac
parent84466e76a9a23a07227fa1da132b4bef83edec6e (diff)
Support for tcmalloc and jemalloc is long dead
When it was originally added to --with-alloc (tcmalloc: f63ffaf3667e218be3538e84e6becc18d5de4334, 54efc5ed83890f0a1166ece3b1e4942bb7922ff7, 0abd71b44144220d2aeec58601929fd0cd1914d6 708b6d4246de915ac960c7b90ee8bb2d966c7d17 "INTEGRATION: CWS configure14: #i59160# allow usage of tcmalloc and system-malloc"; jemalloc: 826a90d68a4dc458585c6d2e647bec17971e9193 "configure25: #i111045# jemalloc"), the old build system's solenv/inc/unxlng*.mk added corresponding -l switches to linker command lines, but it appears that was never carried over into the new build system. And even if the AC_CHECL_LIB calls in configure.ac prior to e612f026de6ca1153c57fb10f0fa75725425a301 "Ensure AC_CHECK_LIB/AC_SEARCH_LIBS do not poison LIBS" would have extended LIBS with the correpsonding -l switches, there appears to be no mechanism in the new build system that would have depended on letting that have any effect on which alloc lib to link against. So the only remaining effect of --with-alloc={tcmalloc,jemalloc} is to set FORCE_SYSALLOC in Library_sal.mk, same as --with-alloc=system does. So whoever still uses the former configure switches should just switch to the latter. (Also adapt the documentation of --with-alloc to reality, "internal" instead of "oo".) Change-Id: Iac0e302c5f9602daf5f8452a0fc1887dc55ee27b Reviewed-on: https://gerrit.libreoffice.org/47178 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 1 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index f0eb940fbae2..b5a7b2b378d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2103,8 +2103,7 @@ with_build_version=$withval,
AC_ARG_WITH(alloc,
AS_HELP_STRING([--with-alloc],
- [Define which allocator to build with (choices are oo, system, tcmalloc, jemalloc).
- Note that on FreeBSD/NetBSD system==jemalloc]),
+ [Define which allocator to build with (choices are internal, system).]),
,)
AC_ARG_WITH(parallelism,
@@ -6476,29 +6475,6 @@ if test "$with_alloc" = "system"; then
AC_MSG_RESULT([system])
ALLOC="SYS_ALLOC"
fi
-if test "$with_alloc" = "tcmalloc"; then
- AC_MSG_RESULT(tcmalloc)
- if ! echo $host_cpu | $GREP -E 'i[[3456]]86' 2>/dev/null >/dev/null; then
- AC_MSG_ERROR([tcmalloc only available/usable on ix86])
- fi
- AC_CHECK_LIB([tcmalloc], [malloc], [:],
- [AC_MSG_ERROR(tcmalloc not found or functional. Install the Google Profiling Tools)], [])
- ALLOC="TCMALLOC"
-fi
-if test "$with_alloc" = "jemalloc"; then
- if test "$_os" != "FreeBSD" -o "$_os" != "NetBSD"; then
- AC_MSG_RESULT(jemalloc)
- save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -pthread"
- AC_CHECK_LIB([jemalloc], [malloc], [:],
- [AC_MSG_ERROR(jemalloc not found or functional. Install the jemalloc allocator.)], [])
- ALLOC="JEMALLOC"
- CFLAGS=$save_CFLAGS
- else
- AC_MSG_RESULT([system])
- ALLOC="SYS_ALLOC"
- fi
-fi
if test "$with_alloc" = "internal" -o -z "$with_alloc"; then
AC_MSG_RESULT([internal])
fi