summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@collabora.com>2019-07-04 08:55:17 +0200
committerJan Holesovsky <kendy@collabora.com>2019-10-24 00:36:08 +0200
commit7e20dcbae47395e7d922ccd9fc5c30dcc205b32f (patch)
tree17577f8f0edb8530a55e816aa74c4eb031960d1a /configure.ac
parent044709575e907ffc74f85c395219207b51370c05 (diff)
android: Allow using SDK and NDK directly from the Android Studio.
Just specify: --with-android-ndk=$HOME/Android/Sdk/ndk-bundle --with-android-sdk=$HOME/Android/Sdk in your autogen.input, install the appropriate components via Android Studio and you are done. Change-Id: Ic99790b781b9017eb4e642380e230d6f7b49e9b7 Reviewed-on: https://gerrit.libreoffice.org/81228 Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com> Reviewed-by: Jan Holesovsky <kendy@collabora.com> (cherry picked from commit 246f1b5b4485b7db9f9584e4b3b819c87e331c0e) Reviewed-on: https://gerrit.libreoffice.org/81328 Tested-by: Jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9c8d512be07b..43cdf69ac8a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -391,7 +391,7 @@ if test -z "$with_android_ndk" -a -e "$SRC_ROOT/external/android-ndk" -a "$build
with_android_ndk="$SRC_ROOT/external/android-ndk"
fi
if test -n "$with_android_ndk"; then
- ANDROID_NDK_HOME=$with_android_ndk
+ eval ANDROID_NDK_HOME=$with_android_ndk
# Set up a lot of pre-canned defaults
@@ -525,7 +525,7 @@ if test -z "$with_android_sdk" -a -e "$SRC_ROOT/external/android-sdk-linux" -a "
with_android_sdk="$SRC_ROOT/external/android-sdk-linux"
fi
if test -n "$with_android_sdk"; then
- ANDROID_SDK_HOME=$with_android_sdk
+ eval ANDROID_SDK_HOME=$with_android_sdk
PATH="$ANDROID_SDK_HOME/platform-tools:$ANDROID_SDK_HOME/tools:$PATH"
fi
AC_SUBST(ANDROID_SDK_HOME)