summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <Michael.Stahl@cib.de>2019-10-11 13:47:59 +0200
committerMichael Stahl <michael.stahl@cib.de>2019-10-14 10:55:38 +0200
commit307b39ac9ced9a31157f9ec7ec1b125fe3f34779 (patch)
treef885d888142f07f2677f5a18e1f03feeeea1c687 /configure.ac
parent9933ec22f0c7a0e787c99f35e919a5a57231dd11 (diff)
configure: remove sanitizer flags from default COMPILER_PLUGINS_CXX
When COMPILER_PLUGINS_CXX is default initialised from $CXX, filter out sanitizer flags, because: a) linking fails with unresolved symbols currently b) typically the slowdown is unhelpful in a build c) if anybody wants a sanitized plugin they can set COMPILER_PLUGINS_CXX manually (init from CXX was added in ad5cbcf6ba0afdc1d8d7405c2641cce8de4a360b) Change-Id: I64dc48fae5f7a23f87b0eee0545add9a1ebd5672 Reviewed-on: https://gerrit.libreoffice.org/80655 Tested-by: Jenkins Reviewed-by: Michael Stahl <michael.stahl@cib.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 717dafe71648..a0c69e8cb3b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7009,7 +7009,7 @@ if test "$COM_IS_CLANG" = "TRUE"; then
fi
# Assume Clang is self-built, but allow overriding COMPILER_PLUGINS_CXX to the compiler Clang was built with.
if test -z "$COMPILER_PLUGINS_CXX"; then
- COMPILER_PLUGINS_CXX=$CXX
+ COMPILER_PLUGINS_CXX=[$(echo $CXX | sed -e 's/-fsanitize=[^ ]*//g')]
fi
clangbindir=$CLANGDIR/bin
if test "$build_os" = "cygwin"; then