summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjan Iversen <jani@libreoffice.org>2017-09-23 10:52:25 +0200
committerjan Iversen <jani@libreoffice.org>2017-09-23 12:56:36 +0200
commitf53b6890525abcf3ea2c1955c8ff26af53c3a8b3 (patch)
tree3dc5adefc98bd6acc6fa8390ce556c2f2b8ff98b /configure.ac
parent7dc82cc2e424b6acddb1aa06338f51db20e6a21e (diff)
iOS, simplified build demands
moved iOS build demand to same location as other os. Change-Id: If235aff2af7b58b26b94cb6818404100fa50d2d8
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 9 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index cd4a190c7501..3626601363ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -624,6 +624,15 @@ darwin*) # Mac OS X or iOS
_os=iOS
test_gtk=no
test_cups=no
+ enable_mpl_subset=yes
+ enable_lotuswordpro=no
+ enable_coinmp=yes
+ enable_lpsolve=no
+ enable_postgresql_sdbc=no
+ enable_extension_integration=no
+ enable_report_builder=no
+ with_theme="tango"
+ with_ppds=no
else
_os=Darwin
if test -n "$LODE_HOME" ; then
@@ -2386,7 +2395,6 @@ fi
# Decide whether to build database connectivity stuff (including
# Base) or not. We probably don't want to on non-desktop OSes.
-
if test -z "$enable_database_connectivity"; then
# --disable-database-connectivity is unfinished work in progress
# and the iOS test app doesn't link if we actually try to use it.
@@ -7262,18 +7270,6 @@ else
fi
AC_SUBST(EPM)
-if test $_os = iOS; then
- enable_mpl_subset=yes
- enable_lotuswordpro=no
- enable_coinmp=yes
- enable_lpsolve=no
- enable_postgresql_sdbc=no
- enable_extension_integration=no
- enable_report_builder=no
- with_theme="tango"
- with_ppds=no
-fi
-
ENABLE_LWP=
if test "$enable_lotuswordpro" = "yes"; then
ENABLE_LWP="TRUE"