summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2017-09-14 16:12:55 +0200
committerMichael Stahl <mstahl@redhat.com>2017-09-15 11:06:18 +0200
commitb29402009831f8a96fd77fc1042c3004c224a350 (patch)
treede1493051d57bcfdb60e5e9e6995a0691b936086 /configure.ac
parent15b973ed64cb0c655b387c5022fc2ff0894520dd (diff)
consistent naming of externals: mysqlcppconn -> mysql-connector-cpp
Change-Id: Ibfb3aa69895eef6023c38e2ff3b7ae98a05f5820 Reviewed-on: https://gerrit.libreoffice.org/42300 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 4c84aa0a008e..00fc1aee1b0d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8243,7 +8243,7 @@ if test "$ENABLE_MARIADBC" = "TRUE"; then
AC_MSG_CHECKING([MySQL Connector/C++])
if test "$with_system_mysql_cppconn" = "yes"; then
AC_MSG_RESULT([external])
- SYSTEM_MYSQL_CPPCONN=TRUE
+ SYSTEM_MYSQL_CONNECTOR_CPP=TRUE
AC_LANG_PUSH([C++])
AC_CHECK_HEADER(mysql_driver.h, [],
[AC_MSG_ERROR(mysql_driver.h not found. install MySQL C++ Connectivity)], [])
@@ -8271,12 +8271,12 @@ int main(int argc, char **argv) {
LIBS=$save_LIBS
else
AC_MSG_RESULT([internal])
- BUILD_TYPE="$BUILD_TYPE MYSQLCPPCONN"
- SYSTEM_MYSQL_CPPCONN=
+ BUILD_TYPE="$BUILD_TYPE MYSQL_CONNECTOR_CPP"
+ SYSTEM_MYSQL_CONNECTOR_CPP=
fi
AC_LANG_POP([C++])
fi
-AC_SUBST(SYSTEM_MYSQL_CPPCONN)
+AC_SUBST(SYSTEM_MYSQL_CONNECTOR_CPP)
dnl ===================================================================
dnl Check for system hsqldb