summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2017-09-20 22:53:45 +0200
committerStephan Bergmann <sbergman@redhat.com>2017-09-20 22:53:45 +0200
commit6c6e0149e0bc9607f4d3e601915e77d6646bc809 (patch)
tree0b7ea4b554479c0bbbfe515c1de5daebee0144cc /configure.ac
parent939436f03d46f39a6bb761c1e04f5fa5c06afa24 (diff)
Pass --with-macosx-version-min-required into external/curl
...which wants to take it from CFLAGS, otherwise defaults to 10.8 Change-Id: I1b086ee8abba1e4b46c67b6b4fe6a05c4ef7a3d8
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fb4f406ef02d..cd4a190c7501 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2706,6 +2706,7 @@ if test $_os = Darwin -o $_os = iOS; then
AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.9--13])
;;
esac
+ MAC_OS_X_VERSION_MIN_REQUIRED_DOTS=$with_macosx_version_min_required
LIBTOOL=/usr/bin/libtool
INSTALL_NAME_TOOL=install_name_tool
@@ -2842,6 +2843,7 @@ AC_SUBST(MACOSX_SDK_PATH)
AC_SUBST(MACOSX_SDK_VERSION)
AC_SUBST(MACOSX_DEPLOYMENT_TARGET)
AC_SUBST(MAC_OS_X_VERSION_MIN_REQUIRED)
+AC_SUBST(MAC_OS_X_VERSION_MIN_REQUIRED_DOTS)
AC_SUBST(MAC_OS_X_VERSION_MAX_ALLOWED)
AC_SUBST(INSTALL_NAME_TOOL)
AC_SUBST(LIBTOOL) # Note that the OS X libtool command is unrelated to GNU libtool