summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNoel Grandin <noelgrandin@gmail.com>2021-05-15 12:13:12 +0200
committerNoel Grandin <noel.grandin@collabora.co.uk>2021-05-18 08:47:09 +0200
commitb0228e4d39656c487300a607117a9e1c6c14620b (patch)
tree5557f02106c4062cc91aef77f79f0606fc3953b6 /configure.ac
parent13c1e3d1e13eb0eabccf29dbd57ae9995b805096 (diff)
make --disable-odk the default
Because developers (especially new ones) don't need this, or the extra dependencies it tends to trigger Update distro and jenkins configs so that the ones that were building ODK before, are still building it after this. Change-Id: I5dc71e70dc457b7921a146008d7d2317b199caab Reviewed-on: https://gerrit.libreoffice.org/c/core/+/115647 Tested-by: Jenkins Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 9929416a188e..d7b831435713 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1433,9 +1433,8 @@ libo_FUZZ_ARG_ENABLE(epm,
)
libo_FUZZ_ARG_ENABLE(odk,
- AS_HELP_STRING([--disable-odk],
- [LibreOffice includes an ODK, office development kit which some packagers may
- wish to build without.])
+ AS_HELP_STRING([--enable-odk],
+ [Enable building the Office Development Kit, the part that extensions need to build against])
)
AC_ARG_ENABLE(mpl-subset,
@@ -8866,7 +8865,7 @@ AC_SUBST(ENABLE_LWP)
dnl ===================================================================
dnl Check for building ODK
dnl ===================================================================
-if test "$enable_odk" = no; then
+if test "$enable_odk" != yes; then
unset DOXYGEN
else
if test "$with_doxygen" = no; then
@@ -8901,7 +8900,7 @@ fi
AC_SUBST([DOXYGEN])
AC_MSG_CHECKING([whether to build the ODK])
-if test "$enable_odk" = "" -o "$enable_odk" != "no"; then
+if test "$enable_odk" = yes; then
AC_MSG_RESULT([yes])
BUILD_TYPE="$BUILD_TYPE ODK"
else