summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2021-04-11 09:20:13 +0200
committerStephan Bergmann <sbergman@redhat.com>2021-04-11 10:35:04 +0200
commit6de0b1710adfba82c96b75a5da6f52633a54c692 (patch)
treecf7255c64f90884a65536bee4af1131231649c91 /configure.ac
parentd9f10d8f0f6bae31dd5ebd9fa00f989d17fc21da (diff)
Get rid of apache-commons-logging
...using Java 1.4 java.util.logging.Logger instead also for the last remaining uses in reportbuilder. (The mention in swext/mediawiki/src/THIRDPARTYLICENSEREADME.html was presumably a leftover from 4b6ceed4a4a9b152905a8b1712ffb9bd61373c16 "swext: Wiki Publisher does not use those apache-commons libraries".) Change-Id: Ia0bc598fe5844ced11cae497548ec7d09453a99d Reviewed-on: https://gerrit.libreoffice.org/c/core/+/113939 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 0 insertions, 40 deletions
diff --git a/configure.ac b/configure.ac
index 3a03dd38290f..46bee5224ce4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2053,11 +2053,6 @@ AC_ARG_WITH(system-gpgmepp,
[Use gpgmepp already on system]),,
[with_system_gpgmepp="$with_system_libs"])
-AC_ARG_WITH(system-apache-commons,
- AS_HELP_STRING([--with-system-apache-commons],
- [Use Apache commons libraries already on system.]),,
- [with_system_apache_commons="$with_system_jars"])
-
AC_ARG_WITH(system-mariadb,
AS_HELP_STRING([--with-system-mariadb],
[Use MariaDB/MySQL libraries already on system.]),,
@@ -2135,11 +2130,6 @@ AC_ARG_WITH(rhino-jar,
[Specify path to jarfile manually.]),
RHINO_JAR=$withval)
-AC_ARG_WITH(commons-logging-jar,
- AS_HELP_STRING([--with-commons-logging-jar=JARFILE],
- [Specify path to jarfile manually.]),
- COMMONS_LOGGING_JAR=$withval)
-
AC_ARG_WITH(system-jfreereport,
AS_HELP_STRING([--with-system-jfreereport],
[Use JFreeReport already on system.]),,
@@ -12317,36 +12307,6 @@ AC_SUBST(LIBREPOSITORY_JAR)
AC_SUBST(LIBFONTS_JAR)
AC_SUBST(LIBSERIALIZER_JAR)
-# this has to be here because both the Wiki Publisher and the SRB use
-# commons-logging
-COMMONS_LOGGING_VERSION=1.2
-if test "$ENABLE_REPORTBUILDER" = "TRUE"; then
- AC_MSG_CHECKING([which Apache commons-* libs to use])
- if test "$with_system_apache_commons" = "yes"; then
- SYSTEM_APACHE_COMMONS=TRUE
- AC_MSG_RESULT([external])
- if test -z $COMMONS_LOGGING_JAR; then
- if test -f /usr/share/java/commons-logging-${COMMONS_LOGGING_VERSION}.jar; then
- COMMONS_LOGGING_JAR=/usr/share/java/commons-logging-${COMMONS_LOGGING_VERSION}.jar
- elif test -f /usr/share/java/commons-logging.jar; then
- COMMONS_LOGGING_JAR=/usr/share/java/commons-logging.jar
- else
- AC_MSG_ERROR(commons-logging.jar replacement not found.)
- fi
- elif ! test -f $COMMONS_LOGGING_JAR; then
- AC_MSG_ERROR(commons-logging.jar not found.)
- fi
- else
- AC_MSG_RESULT([internal])
- SYSTEM_APACHE_COMMONS=
- BUILD_TYPE="$BUILD_TYPE APACHE_COMMONS"
- NEED_ANT=TRUE
- fi
-fi
-AC_SUBST(SYSTEM_APACHE_COMMONS)
-AC_SUBST(COMMONS_LOGGING_JAR)
-AC_SUBST(COMMONS_LOGGING_VERSION)
-
# scripting provider for BeanShell?
AC_MSG_CHECKING([whether to build support for scripts in BeanShell])
if test "${enable_scripting_beanshell}" != "no" -a "x$with_java" != "xno"; then