summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2020-10-31 11:49:00 +0200
committerTor Lillqvist <tml@collabora.com>2020-10-31 11:39:46 +0100
commit7ca79cfca0667b5173fd96889304d98a5fbb2ce2 (patch)
tree0ba998bbc7d3fda6c5aa64ac828298e63949a9f5 /configure.ac
parent61e8c19f41f117bcf4b4b709aebb1245a05a206d (diff)
Set CPPFLAGS instead of the INCLUDE environment variable
INCLUDE is not exported from WSL to Win32 programs without including it in the list of environment variable names in the WSLENV environment variable, and I think we want to minimize the number that need to be mentioned there. Should not affect Cygwin builds. Change-Id: I0af480873badac446305e396b69eec360eb8a270 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/105098 Tested-by: Jenkins Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a79458301f9b..e0a72723eaeb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3967,7 +3967,8 @@ if test "$_os" = "WINNT"; then
# Remove /cl.exe from CC case insensitive
AC_MSG_NOTICE([found Visual C++ $vcyear])
- export INCLUDE=`cygpath -d "$COMPATH/Include"`
+ main_include_dir=`cygpath -d -m "$COMPATH/Include"`
+ CPPFLAGS="$CPPFLAGS -I$main_include_dir"
PathFormat "$COMPATH"
COMPATH=`win_short_path_for_make "$formatted_path"`