summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2016-03-17 12:20:27 -0500
committerNorbert Thiebaud <nthiebaud@gmail.com>2016-03-17 18:44:43 +0000
commit9ffa51c3cb27cf3ec58c24c8e5b41cd2bf09fd5b (patch)
tree8225f284ab0fb451b34a1c58f927594694e39203 /configure.ac
parent0bd43b8c782135e5eb3018ee345a3bd409419a1b (diff)
clang and ccache do not play nice if CCACHE_CCP2=YES is not set
that cause surious warning that are turned into error with -Werror indicate that this will cause errors (not only warning) and disable ccache if it was an implicit enable-ccache. error out if it was an explicit --enable-ccache Change-Id: I351af8b8d73175cd2ce9e52ee3c376ba6a387af1 Reviewed-on: https://gerrit.libreoffice.org/23338 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Norbert Thiebaud <nthiebaud@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 23b6fb0a7d3a..c2bb6566964d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3793,8 +3793,13 @@ AC_SUBST(COM_IS_CLANG)
if test "$CCACHE" != "" -a "$COM_IS_CLANG" = TRUE; then
if test -z "$CCACHE_CPP2"; then
- AC_MSG_WARN([Using ccache with Clang without CCACHE_CPP2 set causes spurious warnings.])
- add_warning "Using ccache with Clang without CCACHE_CPP2 set causes spurious warnings."
+ if test "$enable_ccache" = "" ; then
+ AC_MSG_WARN([Using ccache with Clang without CCACHE_CPP2 set causes spurious warnings/errors.])
+ add_warning "Using ccache with Clang without CCACHE_CPP2 set causes spurious warnings/errors. Disabling it."
+ CCACHE=
+ else
+ AC_MSG_ERROR([Using --enable-ccache with Clang without CCACHE_CPP2 set causes spurious warnings/errors.])
+ fi
fi
fi