summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2018-09-28 23:02:17 +0200
committerRene Engelhard <rene@debian.org>2018-10-03 10:12:34 +0200
commitf104b3cafee63b47a735cfdce0f05dab2eedbb91 (patch)
treef3ffc15f8c36d2772d1945d4571d8f28ac00c785 /configure.ac
parent0b2bf16f2d7794638e4ca72fc3616330b7b76d0c (diff)
tdf#72987 run firebird test for little endian only for now
since those old(er) files still use the endianness-depending format. And remove x64 from the filename... Change-Id: I24e56cd8561c2ec6a1f77a66907c14cdea8248b6 Reviewed-on: https://gerrit.libreoffice.org/60916 Tested-by: Jenkins Reviewed-by: Rene Engelhard <rene@debian.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 86eef4c0c32a..5f0f7080bced 100644
--- a/configure.ac
+++ b/configure.ac
@@ -812,6 +812,13 @@ haiku*)
;;
esac
+if test "$_os" != "WINNT"; then
+AC_C_BIGENDIAN([ENDIANNESS=big], [ENDIANNESS=little])
+else
+ENDIANNESS=little
+fi
+AC_SUBST(ENDIANNESS)
+
if test "$_os" = "Android" ; then
# Verify that the NDK and SDK options are proper
if test -z "$with_android_ndk"; then