summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-09-18 08:39:21 +0200
committerStephan Bergmann <sbergman@redhat.com>2018-09-18 11:52:04 +0200
commita8eb515599526b5b69647a842b2889b6f56de2c8 (patch)
tree3f2d0abcb815a08acbc9a81046d6e2687d4708d1 /configure.ac
parent925e2edb6f3f8fffcff9eddb31ed18bc77e2a690 (diff)
macOS SDK 10.14 is out
Change-Id: Iab7bc66db94fe02bb3714234d68b3e2fc3569fdf Reviewed-on: https://gerrit.libreoffice.org/60657 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8515564d5723..2d41daddc75e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2713,7 +2713,7 @@ if test $_os = Darwin -o $_os = iOS; then
# higher than or equal to the minimum required should be found.
AC_MSG_CHECKING([what Mac OS X SDK to use])
- for _macosx_sdk in ${with_macosx_sdk-10.13 10.12}; do
+ for _macosx_sdk in ${with_macosx_sdk-10.14 10.13 10.12}; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${_macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
with_macosx_sdk="${_macosx_sdk}"
@@ -2748,6 +2748,9 @@ if test $_os = Darwin -o $_os = iOS; then
10.13)
MACOSX_SDK_VERSION=101300
;;
+ 10.14)
+ MACOSX_SDK_VERSION=101400
+ ;;
*)
AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.9--13])
;;
@@ -2784,6 +2787,9 @@ if test $_os = Darwin -o $_os = iOS; then
10.13)
MAC_OS_X_VERSION_MIN_REQUIRED="101300"
;;
+ 10.14)
+ MAC_OS_X_VERSION_MIN_REQUIRED="101400"
+ ;;
*)
AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.9--13])
;;
@@ -2825,6 +2831,9 @@ if test $_os = Darwin -o $_os = iOS; then
10.13)
MAC_OS_X_VERSION_MAX_ALLOWED="101300"
;;
+ 10.14)
+ MAC_OS_X_VERSION_MAX_ALLOWED="101400"
+ ;;
*)
AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.9--13])
;;