summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2017-03-09 15:29:14 +0100
committerMichael Stahl <mstahl@redhat.com>2017-03-09 15:31:03 +0100
commit9e9c7d8b541448fd6022837633d50baa5bbfab69 (patch)
tree979980ef6287b45e57068ec694cc70d9409594fe /configure.ac
parent524e36f8071530c4706304a305402944a4a32dfa (diff)
configure: find the MSMs where MSVC 2017 Release hides them
Change-Id: Id98d73eef46d63686745bf6cd3482b18c7223c3a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d1b813fbafe5..dc837c55c487 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5336,6 +5336,12 @@ find_msms()
my_msm_dir="$VC_PRODUCT_DIR/redist/MSVC/$vcbuildnumber/MergeModules/"
if test -e "$my_msm_dir/$my_msm_file"; then
msmdir=$my_msm_dir
+ else
+ # got everything in 14.10.15017 except the MSMS in 25008... huh?
+ my_msm_dir="$VC_PRODUCT_DIR/redist/MSVC/14.10.25008/MergeModules/"
+ if test -e "$my_msm_dir/$my_msm_file"; then
+ msmdir=$my_msm_dir
+ fi
fi
fi
@@ -5347,6 +5353,7 @@ find_msms()
AC_MSG_ERROR([not found])
else
AC_MSG_WARN([not found])
+ add_warning "MSM $my_msm_file not found"
fi
fi
}