summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <Michael.Stahl@cib.de>2018-04-03 13:16:53 +0200
committerMarkus Mohrhard <markus.mohrhard@googlemail.com>2018-04-07 11:27:41 +0200
commite336b70550a5615a9b6fd1848c5785fe54c3156a (patch)
tree2b994bbcca4390cc23ea59a8cd5e7ceef33f6791 /configure.ac
parentaee1904446cd0508cdf06fd23155373b5018dfed (diff)
configure: check for EGL header if EGL is required
Change-Id: Id7501b9adcd817ce84bfde3a928fe8b4c7e7e01f Reviewed-on: https://gerrit.libreoffice.org/52330 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de> (cherry picked from commit e2e3118465411448a3b1f5e56c3456384c009f99) Reviewed-on: https://gerrit.libreoffice.org/52382 Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk> Reviewed-by: Markus Mohrhard <markus.mohrhard@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6ab7bc51f4bc..4e50fe94a4e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9711,6 +9711,8 @@ if test "x$enable_gtk3" = "xyes"; then
dnl We require egl only for the gtk3 plugin. Otherwise we use glx.
if test "$with_system_epoxy" != "yes"; then
AC_CHECK_LIB(EGL, eglMakeCurrent, [:], AC_MSG_ERROR([libEGL required.]))
+ AC_CHECK_HEADER(EGL/eglplatform.h, [],
+ [AC_MSG_ERROR(EGL headers not found. install mesa-libEGL-devel)], [])
fi
fi
AC_SUBST(GTK3_LIBS)