summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjan Iversen <jani@libreoffice.org>2017-11-20 16:07:09 +0100
committerjan Iversen <jani@libreoffice.org>2017-11-21 09:20:17 +0100
commitd015a6e4e3ae72c38bfb0516c2229daf2254e3d0 (patch)
tree2084a217a39ffbf3a4dac9637cd7f33d2230ef7a /configure.ac
parent30af6599d59067a8da6dc4075e80069e80e25f09 (diff)
iOS, removed visibility=hidden
Seems visibility=hidden gives debug problem, with templated constructors (at least the debugger did not accept breakpoint correctly). Change-Id: I094dc68ffd06516b31ebc649649fad923b903d75
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 0d2b8aca01a6..e634474cffb8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2877,14 +2877,11 @@ if test $_os = iOS; then
if test "$ENABLE_LTO" = TRUE; then
lto=-flto
fi
- # Just add -fvisibility=hidden to CC and CXX directly so that the 3rd-party libs also
- # get compiled with it, to avoid ld warnings when linking all that together into one
- # executable.
stdlib="-stdlib=libc++"
- CC="`xcrun -find clang` -arch $host_cpu -fvisibility=hidden -isysroot $sysroot $lto $versionmin"
- CXX="`xcrun -find clang++` -arch $host_cpu -fvisibility=hidden $stdlib -isysroot $sysroot $lto $versionmin"
+ CC="`xcrun -find clang` -arch $host_cpu -isysroot $sysroot $lto $versionmin"
+ CXX="`xcrun -find clang++` -arch $host_cpu $stdlib -isysroot $sysroot $lto $versionmin"
INSTALL_NAME_TOOL=`xcrun -find install_name_tool`
AR=`xcrun -find ar`