summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2018-03-18 22:25:36 +0100
committerCaolán McNamara <caolanm@redhat.com>2018-03-26 18:07:40 +0200
commit74d438f716d9cef165c78f950d4c53a46c37503c (patch)
tree3642a368245a0871ff61630ab277bcebc1d4327c /configure.ac
parent169fe61fe32587897188ed5b3619af34f394731d (diff)
gpg4libre: fix failing gpg test due to over-long filenames
This squashes the following commits: From f68929ac611fdda19c1ee413effc59d33aa5ef97 Mon Sep 17 00:00:00 2001 From: Thorsten Behrens <Thorsten.Behrens@CIB.de> Date: Fri, 9 Mar 2018 01:38:26 +0100 Subject: gpg4libre: fix failing gpg test due to over-long filenames With long workdir path, gpg sometimes fails with 'gpg: can't connect to the agent: File name too long' error. WK recommends to create preferred socket dir under /run/user, needs prepping though via gpgconf. See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=84720 From d7ecf4a4e37a9eeffa2b40f9fe5a2e6a8f90c876 Mon Sep 17 00:00:00 2001 From: Rene Engelhard <rene@debian.org> Date: Sun, 18 Mar 2018 11:25:41 +0100 Subject: properly check for gpgconf (and --create-socketdir) working From d6ed1d415d36809d784af780231258ea0ee1024f Mon Sep 17 00:00:00 2001 From: Rene Engelhard <rene@debian.org> Date: Sun, 18 Mar 2018 19:06:58 +0100 Subject: actually add GPGCONF to config_host.mk.in From 7a95ee8d0badb2cbbd137a6e18af1bada35ae933 Mon Sep 17 00:00:00 2001 From: Rene Engelhard <rene@debian.org> Date: Sun, 18 Mar 2018 19:26:45 +0100 Subject: actually add HAVE_GPGCONF_SOCKETDIR to config_host.mk.in... From 5204a5145d8232ea0650144fb4756c38303ef06e Mon Sep 17 00:00:00 2001 From: Rene Engelhard <rene@debian.org> Date: Sun, 18 Mar 2018 19:28:55 +0100 Subject: revert accidentially comitted local changes :( From bc358d39ac985914160e8aaa23b29469470c032b Mon Sep 17 00:00:00 2001 From: Rene Engelhard <rene@debian.org> Date: Sun, 18 Mar 2018 20:36:45 +0100 Subject: this is sh, not make... Change-Id: I7880fd7eee57cedc19b72348b45f0c1389409fe6 Reviewed-on: https://gerrit.libreoffice.org/51521 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Caolán McNamara <caolanm@redhat.com> Tested-by: Caolán McNamara <caolanm@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 24eb7d846985..6ab7bc51f4bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10164,6 +10164,27 @@ elif test "$_os" = "Linux" -o "$_os" = "Darwin" \
# gpg installation to run OpenPGP signature verification
AC_DEFINE([HAVE_FEATURE_GPGVERIFY])
fi
+ if test "$_os" = "Linux"; then
+ uid=`id -u`
+ AC_MSG_CHECKING([for /run/user/$uid])
+ if test -d /run/user/$uid; then
+ AC_MSG_RESULT([yes])
+ AC_PATH_PROG(GPGCONF, gpgconf)
+ AC_MSG_CHECKING([for gpgconf --create-socketdir... ])
+ if $GPGCONF --dump-options > /dev/null ; then
+ if $GPGCONF --dump-options | grep -q create-socketdir ; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([HAVE_GPGCONF_SOCKETDIR])
+ else
+ AC_MSG_RESULT([no])
+ fi
+ else
+ AC_MSG_RESULT([no. missing or broken gpgconf?])
+ fi
+ else
+ AC_MSG_RESULT([no])
+ fi
+ fi
fi
AC_SUBST(ENABLE_GPGMEPP)
AC_SUBST(SYSTEM_GPGMEPP)
@@ -10173,6 +10194,8 @@ AC_SUBST(LIBASSUAN_CFLAGS)
AC_SUBST(LIBASSUAN_LIBS)
AC_SUBST(GPGMEPP_CFLAGS)
AC_SUBST(GPGMEPP_LIBS)
+AC_SUBST(GPGCONF)
+AC_SUBST(HAVE_GPGCONF_SOCKETDIR)
AC_MSG_CHECKING([whether to build the Wiki Publisher extension])
if test "x$enable_ext_wiki_publisher" = "xyes" -a "x$enable_extension_integration" != "xno" -a "$with_java" != "no"; then