summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjan Iversen <jani@libreoffice.org>2017-11-24 08:24:12 +0100
committerjan Iversen <jani@libreoffice.org>2017-11-24 09:10:22 +0100
commit99534540df148513fc0bb9622b7285e10b285ccb (patch)
treec080f0d865e7dce4acf969607ea0ae9283f7e252 /configure.ac
parent944da4b735d7c88fa7b7c200ea4c75dd1a6aa00e (diff)
iOS, added IOS_DEPLOYMENT_VERSION
Change-Id: Ie72c8303011df8a4e0e489ab505e619bd7a40e12
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8e0822caac64..5e50660f7aea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2845,17 +2845,17 @@ dnl ===================================================================
if test $_os = iOS; then
AC_MSG_CHECKING([what iOS SDK to use])
+ current_sdk_ver=11.1
if test "$enable_ios_simulator" = "yes"; then
platform=iPhoneSimulator
- versionmin=-mios-simulator-version-min=11.1
+ versionmin=-mios-simulator-version-min=$current_sdk_ver
else
platform=iPhoneOS
- versionmin=-miphoneos-version-min=11.1
+ versionmin=-miphoneos-version-min=$current_sdk_ver
fi
xcode_developer=`xcode-select -print-path`
- current_sdk_ver=11.1
- for sdkver in 11.1; do
+ for sdkver in $current_sdk_ver; do
t=$xcode_developer/Platforms/$platform.platform/Developer/SDKs/$platform$sdkver.sdk
if test -d $t; then
ios_sdk=$sdkver
@@ -2871,6 +2871,7 @@ if test $_os = iOS; then
AC_MSG_RESULT($sysroot)
IOS_SDK=`echo $platform | tr A-Z a-z`$ios_sdk
+ IOS_DEPLOYMENT_VERSION=$current_sdk_ver
# LTO is not really recommended for iOS builds,
# the link time will be astronomical
@@ -2892,6 +2893,7 @@ if test $_os = iOS; then
fi
AC_SUBST(IOS_SDK)
+AC_SUBST(IOS_DEPLOYMENT_VERSION)
AC_MSG_CHECKING([whether to treat the installation as read-only])