summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2017-11-16 18:01:23 +0100
committerStephan Bergmann <sbergman@redhat.com>2017-11-16 18:01:23 +0100
commit20f6242b2c50876754368eeadcdc8902cf76e79a (patch)
tree4ba1db157ed957a65a3967a4c8c763703c00a8b9 /configure.ac
parent2f672e801b6656e4399de12290c56ec3d9f9ad36 (diff)
Add comment to eventually remove __float128 workaround
Change-Id: I9f786bb34d05febe6c7393bde8ca9d9ce18f41c9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ffb1fdf0c850..993d85794802 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6060,6 +6060,9 @@ return !(i != 0 && j != 0);
AC_LANG_POP([C++])
CXXFLAGS=$save_CXXFLAGS
+dnl Clang 3.9 supports __float128 since
+dnl <http://llvm.org/viewvc/llvm-project?view=revision&revision=268898> "Enable support for
+dnl __float128 in Clang and enable it on pertinent platforms":
AC_MSG_CHECKING([whether $CXX supports C++11 without __float128 compile error])
save_CXXFLAGS=$CXXFLAGS
CXXFLAGS="$CXXFLAGS $CXXFLAGS_CXX11"