summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2019-10-08 12:30:20 +0200
committerStephan Bergmann <sbergman@redhat.com>2019-10-08 15:56:19 +0200
commitea3d4e806cbdde18173da92187329f1ac2177e14 (patch)
tree019a38e3a6968b22ca6f38bd12bcd440a76e032e /configure.ac
parent9f981916f21ac38bb81d14b55ac031961ee732fd (diff)
Fix CXX_BASE for clang-cl builds on Windows
...where the configure messages confusingly mentioned cl.exe instead of clang.exe (but the actual checks correctly used $CXX being clang) Change-Id: I9e0c6e1ab8ba64c45f752b413c3e6c22182506ac Reviewed-on: https://gerrit.libreoffice.org/80442 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 4 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 5d90f3e2d7d6..0943619e7701 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3518,7 +3518,6 @@ if test "$_os" = "WINNT"; then
# This gives us a posix path with 8.3 filename restrictions
MSVC_CXX=`win_short_path_for_make "$MSVC_CXX"`
- CXX_BASE=`first_arg_basename "$MSVC_CXX"`
fi
if test -z "$CC"; then
@@ -3529,6 +3528,10 @@ if test "$_os" = "WINNT"; then
dnl since MSVC 2012, default for x86 is -arch:SSE2:
MSVC_CXX="$MSVC_CXX -arch:SSE"
fi
+ if test -z "$CXX"; then
+ CXX=$MSVC_CXX
+ CXX_BASE=`first_arg_basename "$CXX"`
+ fi
if test -n "$CC"; then
# Remove /cl.exe from CC case insensitive
@@ -5876,11 +5879,6 @@ if test "$_os" != "WINNT"; then
if test -z "$CXX_BASE"; then
CXX_BASE=`first_arg_basename "$CXX"`
fi
-else
- if test -n "$CC" -a -z "$CXX"; then
- CXX="$CC"
- CXX_BASE="$CC_BASE"
- fi
fi
dnl check for GNU C++ compiler version