summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2019-10-05 16:27:48 +0200
committerLuboš Luňák <l.lunak@collabora.com>2019-10-07 21:57:32 +0200
commit79ca031fb2e8802aa4383362f83306fad6895729 (patch)
treefd07ced6096d1df707d2b087483c99d606cf7e43 /configure.ac
parentad5cbcf6ba0afdc1d8d7405c2641cce8de4a360b (diff)
make the clang plugins configure check faster
Use a header which is not so expensive to parse/compile. Change-Id: I4197fb16938b19c18fed541dbf94bf2c97a60e66 Reviewed-on: https://gerrit.libreoffice.org/80301 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 156dca7b1ed0..7ba93a3f5247 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7036,7 +7036,7 @@ if test "$COM_IS_CLANG" = "TRUE"; then
CXXCPP="$COMPILER_PLUGINS_CXX -E"
CPPFLAGS="$COMPILER_PLUGINS_CXXFLAGS"
CXXFLAGS="$COMPILER_PLUGINS_CXXFLAGS"
- AC_CHECK_HEADER(clang/AST/RecursiveASTVisitor.h,
+ AC_CHECK_HEADER(clang/Basic/SourceLocation.h,
[COMPILER_PLUGINS=TRUE],
[
if test "$compiler_plugins" = "yes"; then
@@ -7053,15 +7053,15 @@ if test "$COM_IS_CLANG" = "TRUE"; then
LIBS="-lclangTooling -lclangDriver -lclangFrontend -lclangParse -lclangSema -lclangEdit \
-lclangAnalysis -lclangAST -lclangLex -lclangSerialization -lclangBasic $COMPILER_PLUGINS_CXX_LINKFLAGS"
AC_LINK_IFELSE([
- AC_LANG_PROGRAM([[#include "clang/Tooling/Tooling.h"]],
- [[ clang::tooling::runToolOnCode( nullptr, "some code" ); ]])
+ AC_LANG_PROGRAM([[#include "clang/Basic/SourceLocation.h"]],
+ [[ clang::FullSourceLoc().dump(); ]])
],[CLANGTOOLLIBS="$LIBS"],[])
fi
if test -z "$CLANGTOOLLIBS"; then
LIBS="-lclang-cpp $COMPILER_PLUGINS_CXX_LINKFLAGS"
AC_LINK_IFELSE([
- AC_LANG_PROGRAM([[#include "clang/Tooling/Tooling.h"]],
- [[ clang::tooling::runToolOnCode( nullptr, "some code" ); ]])
+ AC_LANG_PROGRAM([[#include "clang/Basic/SourceLocation.h"]],
+ [[ clang::FullSourceLoc().dump(); ]])
],[CLANGTOOLLIBS="$LIBS"],[])
fi
AC_MSG_RESULT([$CLANGTOOLLIBS])