summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThorsten Behrens <thorsten.behrens@allotropia.de>2022-12-11 00:19:53 +0100
committerThorsten Behrens <thorsten.behrens@allotropia.de>2022-12-12 23:07:50 +0000
commite2af567b99d61a209da21657ec6e0cf641034e86 (patch)
tree7f8424faa31d2b5f5891595562df0ee7c301bf19 /configure.ac
parente11a61b5630396f0b6d8312fbc7e12337e1f645e (diff)
Replace backslashes in config params before usage in cxx files
With cbfac11330882c7d0a817b6c37a08b2ace2b66f4, LOKit tries to pass full configure line on via JSON - which, on Windows, might contain backslashes and other nasties, so we better try to clean that up here. Change-Id: I8314783fc6f49e9b2b374d94448ed735de39bf81 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/143940 Tested-by: Jenkins Reviewed-by: Thorsten Behrens <thorsten.behrens@allotropia.de> (cherry picked from commit b60dfc2928ef9763452c57f06073185456310609) Reviewed-on: https://gerrit.libreoffice.org/c/core/+/143964
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c2a7159ea9e5..9e92838241e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -522,7 +522,9 @@ AC_DEFINE_UNQUOTED(LIBO_VERSION_PATCH,$LIBO_VERSION_PATCH)
LIBO_THIS_YEAR=`date +%Y`
AC_DEFINE_UNQUOTED(LIBO_THIS_YEAR,$LIBO_THIS_YEAR)
-AC_DEFINE_UNQUOTED([BUILDCONFIG],[["$ac_configure_args"]],[Options passed to configure script])
+# replace backslashes, to get a valid c++ string
+config_args=$(echo $ac_configure_args | tr '\\' '/')
+AC_DEFINE_UNQUOTED([BUILDCONFIG],[["$config_args"]],[Options passed to configure script])
dnl ===================================================================
dnl Product version