summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndras Timar <andras.timar@collabora.com>2022-02-11 21:56:12 +0100
committerAndras Timar <andras.timar@collabora.com>2023-01-23 21:46:01 +0100
commitc96c7c4da94b994b116d75c323da7eec62664b66 (patch)
treec1a72b49b2d21b322be560ad0bb4ce471802bb8e /configure.ac
parent6d4d944bf659d805570b260f1ab1a6f9f0ebaaa0 (diff)
[cp] Collabora Office branding
Change-Id: I694d9a6c508853d2d980f76cc259ce1e39149da4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 4 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index d42e5d508bb7..8483d2517e0b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,7 +9,7 @@ dnl in order to create a configure script.
# several non-alphanumeric characters, those are split off and used only for the
# ABOUTBOXPRODUCTVERSIONSUFFIX in openoffice.lst. Why that is necessary, no idea.
-AC_INIT([LibreOffice],[7.5.1.0.0+],[],[],[http://documentfoundation.org/])
+AC_INIT([Collabora Office],[23.05.0.1],[],[],[https://collaboraoffice.com/])
dnl libnumbertext needs autoconf 2.68, but that can pick up autoconf268 just fine if it is installed
dnl whereas aclocal (as run by autogen.sh) insists on using autoconf and fails hard
@@ -453,6 +453,7 @@ if test -n "$with_product_name" -a "$with_product_name" != no; then
fi
if test "$enable_release_build" = "" -o "$enable_release_build" = "no"; then
PRODUCTNAME="${PRODUCTNAME}Dev"
+ PRODUCTNAME=AC_PACKAGE_NAME
fi
AC_MSG_RESULT([$PRODUCTNAME])
AC_SUBST(PRODUCTNAME)
@@ -495,15 +496,8 @@ test -n "$LIBO_VERSION_SUFFIX" && LIBO_VERSION_SUFFIX=".$LIBO_VERSION_SUFFIX"
# CFBundleShortVersionString at
# https://developer.apple.com/documentation/bundleresources/information_property_list/cfbundleshortversionstring
-# But that is enforced only in the App Store, and we apparently want to break the rules otherwise.
-
-if test "$enable_macosx_sandbox" = yes; then
- MACOSX_BUNDLE_SHORTVERSION=$LIBO_VERSION_MAJOR.$LIBO_VERSION_MINOR.`expr $LIBO_VERSION_MICRO '*' 1000 + $LIBO_VERSION_PATCH`
- MACOSX_BUNDLE_VERSION=$MACOSX_BUNDLE_SHORTVERSION
-else
- MACOSX_BUNDLE_SHORTVERSION=$LIBO_VERSION_MAJOR.$LIBO_VERSION_MINOR.$LIBO_VERSION_MICRO.$LIBO_VERSION_PATCH
- MACOSX_BUNDLE_VERSION=$MACOSX_BUNDLE_SHORTVERSION$LIBO_VERSION_SUFFIX
-fi
+MACOSX_BUNDLE_SHORTVERSION=$LIBO_VERSION_MAJOR.$LIBO_VERSION_MINOR.`expr $LIBO_VERSION_MICRO '*' 1000 + $LIBO_VERSION_PATCH`
+MACOSX_BUNDLE_VERSION=$MACOSX_BUNDLE_SHORTVERSION
AC_SUBST(LIBO_VERSION_MAJOR)
AC_SUBST(LIBO_VERSION_MINOR)