summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2018-04-13 11:20:08 +0200
committerLuboš Luňák <l.lunak@collabora.com>2018-04-18 11:32:34 +0200
commitab8bf5533f8de9bb1aa9dc83e650e4eccf0fcac3 (patch)
tree2f9b1a1a2462c09fa32301b6e42325ad8bb2578e /configure.ac
parent32d96fdab8fbedba81e21f1d01cf35f536f623c8 (diff)
avoid error message from configure about clang's header for compiler plugins
The header fails to compile without C++11 with recent Clang, and although configure currently passes the check because the existence of the header is considered to be enough, it still prints a distracting error message about the compile check failing. Change-Id: Icf037114b73122f193629e17a8e2b0e2bca3a990
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f21424e15810..bdc374699cb9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6568,7 +6568,7 @@ if test "$COM_IS_CLANG" = "TRUE"; then
# compiler plugins must be built with "native" compiler that was used to build Clang itself:
: "${COMPILER_PLUGINS_CXX=g++}"
CXX=$COMPILER_PLUGINS_CXX
- CPPFLAGS="$CPPFLAGS -I$CLANGDIR/include -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS"
+ CPPFLAGS="$CPPFLAGS $CXXFLAGS_CXX11 -I$CLANGDIR/include -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS"
AC_CHECK_HEADER(clang/AST/RecursiveASTVisitor.h,
[COMPILER_PLUGINS=TRUE],
[