summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndras Timar <andras.timar@collabora.com>2022-01-29 17:42:00 +0100
committerAndras Timar <andras.timar@collabora.com>2022-01-31 22:25:56 +0100
commit9bf6834fa685b7b33883dfbf93d3e68ed74f1c96 (patch)
treef71bb3f657f58a4252046dff416585076ba06ea0 /configure.ac
parent6daaff869e9504fd2911a696c68417f7c4567aa4 (diff)
[cp] create debuginfo packages in one round
Change-Id: I644af21de7d184daa902f1ef47c813647baa2799
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a50e35e599d5..b9be6613c297 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4612,16 +4612,24 @@ if test -z "$enable_symbols"; then
fi
if test "$enable_symbols" = yes; then
ENABLE_SYMBOLS_FOR=all
+ ENABLE_STRIP=
+ DISABLE_STRIP=1
AC_MSG_RESULT([yes])
elif test "$enable_symbols" = no; then
ENABLE_SYMBOLS_FOR=
+ ENABLE_STRIP=1
+ DISABLE_STRIP=
AC_MSG_RESULT([no])
else
# Selective debuginfo.
ENABLE_SYMBOLS_FOR="$enable_symbols"
+ ENABLE_STRIP=
+ DISABLE_STRIP=1
AC_MSG_RESULT([for "$enable_symbols"])
fi
AC_SUBST(ENABLE_SYMBOLS_FOR)
+AC_SUBST(ENABLE_STRIP)
+AC_SUBST(DISABLE_STRIP)
if test -n "$with_android_ndk" -a \( -n "$ENABLE_SYMBOLS" -o -n "$ENABLE_DEBUG" -o -n "$ENABLE_DBGUTIL" \) -a "$ENABLE_DEBUGINFO_FOR" = "all"; then
# Building on Android with full symbols: without enough memory the linker never finishes currently.