summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndras Timar <andras.timar@collabora.com>2022-02-22 13:22:54 +0100
committerAndras Timar <andras.timar@collabora.com>2023-01-28 11:29:44 +0100
commit34fb73145f0c6eae27fe5da57d71d34b7af6e17e (patch)
treefba7ce6a9508d06524abaf5225569eef47f8dabf /configure.ac
parent2d4c01e44842722140995a9a72f2b6bdf1d71212 (diff)
eliminate ENABLE_STRIP because it causes build issues in nss (Android)
Change-Id: Ie229f444d80a5f441576649e22b0c56c67cd3424 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/130347 Tested-by: Andras Timar <andras.timar@collabora.com> Reviewed-by: Andras Timar <andras.timar@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 0 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 8b3693669c9d..24a8c9ec6471 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4885,25 +4885,16 @@ if test -z "$enable_symbols"; then
fi
if test "$enable_symbols" = yes; then
ENABLE_SYMBOLS_FOR=all
- ENABLE_STRIP=
- DISABLE_STRIP=1
AC_MSG_RESULT([yes])
elif test "$enable_symbols" = no; then
ENABLE_SYMBOLS_FOR=
- ENABLE_STRIP=1
- DISABLE_STRIP=
AC_MSG_RESULT([no])
else
# Selective debuginfo.
ENABLE_SYMBOLS_FOR="$enable_symbols"
- ENABLE_STRIP=
- DISABLE_STRIP=1
AC_MSG_RESULT([for "$enable_symbols"])
fi
AC_SUBST(ENABLE_SYMBOLS_FOR)
-AC_SUBST(ENABLE_STRIP)
-AC_SUBST(DISABLE_STRIP)
-
if test -n "$with_android_ndk" -a \( -n "$ENABLE_SYMBOLS" -o -n "$ENABLE_DEBUG" -o -n "$ENABLE_DBGUTIL" \) -a "$ENABLE_DEBUGINFO_FOR" = "all"; then
# Building on Android with full symbols: without enough memory the linker never finishes currently.
AC_MSG_CHECKING([whether enough memory is available for linking])