summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndras Timar <andras.timar@collabora.com>2018-04-23 20:18:45 +0200
committerAndras Timar <andras.timar@collabora.com>2023-01-28 11:29:13 +0100
commit2d4c01e44842722140995a9a72f2b6bdf1d71212 (patch)
tree794aa0bead937ba0c1f8d284761ce0ea8258dd0b /configure.ac
parent99dc792086d294674b7c1c54eb63b672120af05b (diff)
[cp] Allow creation of debuginfo and debugsource rpm/deb packages
Change-Id: Idae5128b58e4cd6f61b8e83664098d195ca67072
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4410d5b21dc0..8b3693669c9d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4885,16 +4885,24 @@ if test -z "$enable_symbols"; then
fi
if test "$enable_symbols" = yes; then
ENABLE_SYMBOLS_FOR=all
+ ENABLE_STRIP=
+ DISABLE_STRIP=1
AC_MSG_RESULT([yes])
elif test "$enable_symbols" = no; then
ENABLE_SYMBOLS_FOR=
+ ENABLE_STRIP=1
+ DISABLE_STRIP=
AC_MSG_RESULT([no])
else
# Selective debuginfo.
ENABLE_SYMBOLS_FOR="$enable_symbols"
+ ENABLE_STRIP=
+ DISABLE_STRIP=1
AC_MSG_RESULT([for "$enable_symbols"])
fi
AC_SUBST(ENABLE_SYMBOLS_FOR)
+AC_SUBST(ENABLE_STRIP)
+AC_SUBST(DISABLE_STRIP)
if test -n "$with_android_ndk" -a \( -n "$ENABLE_SYMBOLS" -o -n "$ENABLE_DEBUG" -o -n "$ENABLE_DBGUTIL" \) -a "$ENABLE_DEBUGINFO_FOR" = "all"; then
# Building on Android with full symbols: without enough memory the linker never finishes currently.