summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2013-04-12 09:51:36 +0200
committerDavid Tardon <dtardon@redhat.com>2013-04-13 09:26:18 +0200
commitea09e0352a82dabc26c713adc1825d89ff824178 (patch)
tree437542f6965395911f3e3fc4b291c262c0c2baf7 /configure.ac
parentddd9e1257562486f1d5e1e58f5287b14633f7995 (diff)
add extra inc. dir for URE headers
This is in preparation for removing gb_ZipPackage. It is only a temporary workaround, as the URE headers can be used directly from $(SRCDIR), once we do the migration of public headers to top-level. This commit should be reverted then. Change-Id: I26b7ad6eb7b33797c174573e3c2f69d295408657
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 11 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 23e3ca4ada41..1d00ebb78b1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3371,11 +3371,20 @@ AC_SUBST(x_OBJCFLAGS)
AC_SUBST(x_OBJCXXFLAGS)
AC_SUBST(x_LDFLAGS)
+dnl ===================================================================
+dnl Product version
+dnl ===================================================================
+AC_MSG_CHECKING([for product version])
+PRODUCTVERSION=AC_PACKAGE_VERSION
+AC_MSG_RESULT([$PRODUCTVERSION])
+AC_SUBST(PRODUCTVERSION)
+
#
# determine CPU, CPUNAME, GUI, GUIBASE, ...
#
LIB64="lib"
SOLARINC=
+SDKDIR="sdk"
case "$host_os" in
@@ -3434,6 +3443,7 @@ darwin*)
OS=MACOSX
RTL_OS=MacOSX
P_SEP=:
+ SDKDIR="LibreOffice${PRODUCTVERSION}_SDK"
case "$host_cpu" in
arm*)
@@ -3918,7 +3928,7 @@ else
INSTDIR=${BUILDDIR}/instdir/${INPATH}
fi
OUTDIR="${SOLARVER}/${INPATH}"
-SOLARINC="-I. -I${SOLARVER}/$INPATH/inc/external -I${SOLARVER}/$INPATH/inc -I$SRC_ROOT/solenv/inc $SOLARINC"
+SOLARINC="-I. -I${SOLARVER}/$INPATH/inc/external -I${SOLARVER}/$INPATH/inc -I${INSTDIR}/${SDKDIR}/include -I$SRC_ROOT/solenv/inc $SOLARINC"
AC_SUBST(COM)
AC_SUBST(CPU)
AC_SUBST(CPUNAME)
@@ -11249,14 +11259,6 @@ AC_SUBST(CURL)
AC_SUBST(MD5SUM)
dnl ===================================================================
-dnl Product version
-dnl ===================================================================
-AC_MSG_CHECKING([for product version])
-PRODUCTVERSION=AC_PACKAGE_VERSION
-AC_MSG_RESULT([$PRODUCTVERSION])
-AC_SUBST(PRODUCTVERSION)
-
-dnl ===================================================================
dnl Dealing with l10n options
dnl ===================================================================
AC_MSG_CHECKING([which languages to be built])