summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Meeks <michael.meeks@suse.com>2013-04-23 14:18:34 +0100
committerMichael Meeks <michael.meeks@suse.com>2013-04-24 13:29:46 +0100
commitdb52fd7123b35d9c3e0ff5868a58195add2a455e (patch)
treeea9ef6220a7701c45a3a71a7230249cac70b7a45 /configure.ac
parent16385c4d1c24a05a7d364854b0a437006eb1e333 (diff)
Add license filtering to configure.
Change-Id: Icd53c6ccfcca25d828d79ad62d1e075869998850
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 34 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 34cc0b3e46e2..a002d93642a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -747,7 +747,7 @@ AC_ARG_ENABLE(pch,
AC_ARG_ENABLE(win-mozab-driver,
AS_HELP_STRING([--enable-win-mozab-driver],
- [LibreOffice includes a driver to connect to Mozilla
+ [LibreOffice includes a driver to connect to Mozilla
address books under Windows, to build with this version, use this option.])
)
@@ -763,6 +763,11 @@ AC_ARG_ENABLE(odk,
wish to build without.])
)
+AC_ARG_ENABLE(mpl-subset,
+ AS_HELP_STRING([--enable-mpl-subset],
+ [Don't compile any pieces which are not MPL or more liberrally licensed])
+)
+
AC_ARG_ENABLE(mathmldtd,
AS_HELP_STRING([--enable-mathmldtd],
[Enable bundling of (modified) MathML 1.01 DTD.])
@@ -1152,6 +1157,11 @@ AC_ARG_ENABLE(postgresql-sdbc,
[Disable the build of the PostgreSQL-SDBC driver.])
)
+AC_ARG_ENABLE(lotuswordpro,
+ AS_HELP_STRING([--disable-lotuswordpro],
+ [Disable the build of the Lotus Word Pro filter.]),
+,enable_lotuswordpro=yes)
+
AC_ARG_ENABLE(coretext,
AS_HELP_STRING([--enable-coretext],
[Use CoreText framework on Mac (instead of ATSU).
@@ -6923,6 +6933,29 @@ printf ("hello world\n");
fi
AC_SUBST(WINEGCC)
+ENABLE_LWP=
+if test "$enable_lotuswordpro" = "yes"; then
+ ENABLE_LWP="TRUE"
+ SCPDEFS="$SCPDEFS -DDISABLE_LWP"
+fi
+AC_SUBST(ENABLE_LWP)
+
+AC_MSG_CHECKING([MPL subset])
+MPL_SUBSET=
+if test "$enable_mpl_subset" = "yes"; then
+ if test "x$enable_postgresql_sdbc" != "xno"; then
+ AC_MSG_ERROR([need to --disable-postgresql-sdbc.])
+ fi
+ if test "$enable_lotuswordpro" = "yes"; then
+ AC_MSG_ERROR([need to --disable-lotuswordpro.])
+ fi
+ MPL_SUBSET="TRUE"
+ AC_MSG_RESULT([only])
+else
+ AC_MSG_RESULT([no restrictions])
+fi
+AC_SUBST(MPL_SUBSET)
+
dnl ===================================================================
dnl Check for gperf
dnl ===================================================================